It's all about the answers!

Ask a question

RQM Reportable REST API filter issue

Steven Tuttle (5079) | asked Jun 11 '15, 2:30 p.m.

      I am running into a strange issue, and was hoping someone might be able to help.  I am supporting a RQM 4.0.6 environment (tomcat frontend, and DB2 database backend).  We are running into issues with running a RqmApi call that uses a filter.  

The following call works:

The following call does not work - it just seems to hang:
https://<server>:<port>/qm/service/<project>/testplan?fields=feed/entry/content/testplan[title='Test Plan']/(identifier|title)

The only difference is the second call should just return information about the testplan with a title of Test Plan, and filter out the other testplan (the part in bold).  I have tried a similar calls on one of our 5.0.2 RQM environments and both calls pass.  

Is there something wrong with the call I am using, or is there something wrong with RqmApi in version 4.0.6?  

I have been told that the second call used to work on this environment, but I personally haven't gotten it to work.  

Could any changes on the server (tomcat) prevent this type of call from succeeding (maybe some configuration was changed from when they said it worked to now when it doesn't work).

Any help would be greatly appreciated!  Thanks!

Have a good day,
Steven J. Tuttle

Don Yang commented Jun 11 '15, 9:42 p.m.

I tried with v4.0.6 (created a named "Test Plan" testplan) and there is no problem in return the expected test plan item in Firefox. I don't see any problem in this Reportable REST API itself. In your environment, whatever title of test plan, you will see the same hanging problem, is that right?
if you try with REST client, would you be able to get any result?

Steven Tuttle commented Jun 15 '15, 9:43 a.m.

 I have tried the URL in the browser, as well as using the Advanced REST client in Chrome.  Any title filter similar to the one shown will hang, and not get a return.  I have tried testplan titles that contain spaces and some that don't, and they all hang.  If I remove the title filter the call returns all testplans as expected, so parts of the RqmApi are working, but for some reason filters are not.  I have tried the title filter on a 5.0.2 environment and that worked fine.  I am thinking something might be messed up on the tomcat server, but no idea what would effect just the RqmApi because the environment itself seems to be working fine.

One answer

permanent link
Paul Slauenwhite (8.4k12) | answered Jun 15 '15, 10:48 a.m.
Hi Steven,

 A couple of comments:

-You can remove the |title selection since it's included in the filter predicate.
-Remember to URL-encode your fields parameter value (if not already handled by your HTTP client).
-Your fields expression looks good.  If the problem persists, please open a PMR.

Steven Tuttle commented Jun 15 '15, 11:24 a.m.

I opened a PMR for additional assistance: 41362,227,000.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.