It's all about the answers!

Ask a question

SMTP error still appears after changing SMTP server


Ernesto Ramirez (13717) | asked Jun 01 '15, 8:13 p.m.
Hi

We have an RTC server which had communication problems with a SMTP server. It seems during some minutes communication was lost and an error appeared:


2015-05-15 16:46:35,901 [WebContainer : 41 @@ 16:46 <unauthenticated> /jts/service/com.ibm.team.jfs.mail.service.IMailerRestService] ERROR com.ibm.team.jfs                                    - CRJZS5074E Unexpected exception sending mail
javax.mail.MessagingException: Could not connect to SMTP host: my.old.smtp.server, port: 25;
  nested exception is:
    java.net.ConnectException: Connection refused


I did a trace and decided to change the SMTP server to one which is the closest in the zone. The server was restarted and no error messages appeared for some days. I tested the SMTP sending a mail an everything worked.

However today the same error message appeared, the weirdest thing is that error message indicates a communication problem with the same old SMTP server.

I modified the SMTP server from jts -->server --> Configuration --> E-mail settings

Nothing has changed, the same "new" SMTP server is configured so I don't see a reason for receiving an error message related to "old" SMTP.

I have searched in Advanced settings and I don't find any other field including the old SMTP server.

Could you please indicate if something else has to be modified?

Regards.

Comments
Lily Wang commented Jun 01 '15, 9:14 p.m.

I don't know the answer. But you can consider to do a mail trace by enable the trace in 'jts/admin > advanced properties', set "Debug mail API" to true. Then you can check from the trace output if the old SMTP server is connected.
If you are using Tomcat, the output is in Tomcat console or catalina.out.
If you are using Websphere, the output is in SystemOut.log.


Donald Nong commented Jun 01 '15, 9:52 p.m.

Are you using any fail-over or load balancing feature on the SMTP servers at all? If so, that may explain why the communication would switch to the old server.

Be the first one to answer this question!


Register or to post your answer.