It's all about the answers!

Ask a question

Can't stop db2 for backup - related to jbe processes?


Alex Mulholland (712111) | asked Jun 10 '09, 9:23 a.m.
Using RTC 1.0.1. We have been stopping RTC and DB2 each night to take an offline backup; RTC stopserver, db2 force applications all, db2stop. This worked fine for several months. Recently though the db2 instance will not stop (even with db2stop force). This appeared to coincide with the addition of more build engines / jbe processes (there are 18 defined, with 8 of those active), and I also noticed an increase in the number of these processes:

db2inst1 23723 23511 0 09:11 pts/2 00:00:01 db2agent (JAZZ) 0

There are currently 18 such processes running.

Any ideas?

Thanks, Alex.

One answer



permanent link
Chris Cawthorne (962719) | answered Jun 10 '09, 11:34 a.m.
We hit this problem intermittently and I think there's a bug in the server.shutdown code that allows the server to not shut down properly. When this happens it hangs on to the db2 connections and then db2 won't stop either. We got round this by writing a shell script like this:

stop RTC (server.shutdown)
do 12 times
wait 5 seconds
look for db2 connections
end
if connections still exist after a minute, look for the RTC process and kill it

This seems to have fixed it

Your answer


Register or to post your answer.