It's all about the answers!

Ask a question

Fetching Iterations using Oslc


Sudipto Sarkar (63334) | asked May 14 '15, 4:43 a.m.
Hi,

 I am trying to get all iterations using oslc as follows:
https://localhost:9443/ccm/oslc/iterations.
But this url is giving me the iterations of all project areas. But I want to retrieve the iterations of a particular Project area. What is the url for this?

Thanks,
Sud

One answer



permanent link
Shawn Maclaga (1963) | answered May 14 '15, 10:17 a.m.
edited May 14 '15, 10:35 a.m.
A working example with the caveat that it's currently marked as a provisional service and may change in the next release:

In the rootservices document:
https://jazz.net/jazz/rootservices

You'll find a section like this:
-- Project areas service. This service is provisional and may change in the next release. --
<jp06:projectAreas rdf:resource="https://jazz.net/jazz/process/project-areas"/>
Use that resource to lookup the project areas.
Within the project-areas service document, locate the project area you're interested in, say "Rational Team Concert" and locate the timelines-url, in this case:
https://jazz.net/jazz/process/project-areas/_1w8aQEmJEduIY7C8B09Hyw/timelines

From here you'll be able to find the iterations for a specific timeline, such as "development":
https://jazz.net/jazz/process/project-areas/_1w8aQEmJEduIY7C8B09Hyw/timelines/_p9eEIGNoEdy7bvk2zwD5rw/iterations

And the child iterations of the RTC 6.0 iteration here:
https://jazz.net/jazz/process/project-areas/_1w8aQEmJEduIY7C8B09Hyw/timelines/_p9eEIGNoEdy7bvk2zwD5rw/iterations/_g_8A0EmGEeS8I8_tB4YpVQ/children

Shawn

Comments
Sudipto Sarkar commented May 29 '15, 6:28 a.m.

Hi Shawn,

 I tried with this use case. I am able to fetch the iterations of a particular project area. Out of these iterations, I chose one and tried to associate while creating a workitem. The fetched iteration is like:

https://localhost:9443/ccm/process/project-areas/-Cg8zv7AEeS61Oblf7UzOg/timelines/-T3Ldf7AEeS61Oblf7UzOg/iterations/-T3Ldv7AEeS61Oblf7UzOg
and trying to put it in the oslc query like:
<rtc_cm:plannedFor rdf:resource="https://localhost:9443/ccm/process/project-areas/
-Cg8zv7AEeS61Oblf7UzOg/timelines/-T3Ldf7AEeS61Oblf7UzOg/iterations/-T3Ldv7AEeS61Oblf7UzOg"/>
But I am getting 409 error while creating that workitem.

Thanks,
Sud


Shawn Maclaga commented May 29 '15, 9:09 a.m.

Hi Sud,
To update the planned for of a workitem with this iteration, you'll need to put the iteration into the expected format.

In your case, that should be:

<rtc_cm:plannedFor rdf:resource="https://localhost:9443/ccm/oslc/iterations/_-T3Ldv7AEeS61Oblf7UzOg"/>;

Your answer


Register or to post your answer.