It's all about the answers!

Ask a question

zimport not setting language definitions


Alex Akilov (1211224) | asked Apr 28 '15, 3:41 p.m.
edited Apr 28 '15, 3:42 p.m.
We're on RTC 5.0.2.  Haven't tried to zimport with this version until now.  However, it appears that zimport does not honor the L:<member>=<Langdef>:<ext> production rule anymore (at least, it assigns the extension but doesn't appear to assign a language definition).  One thing that's different is that we now have our language definitions defined in a different project area from the one that contains the source but I'm not sure if that's related.

One answer



permanent link
Pascal Fantoni (2111) | answered May 06 '15, 1:10 p.m.
JAZZ DEVELOPER
Hi Alex, Normally zimport version 5.0.2 should honor the line L:<member>=<langdef>:<ext> as previously.
Could you run the zimport with the verbose option (-v), if the Language Definition is not found you should see the following message:
CRHTC0624W Could not find a language definition named <LD_Name> to associate with zFile <Member_Name>.

Comments
Alex Akilov commented May 20 '15, 6:05 p.m.

 Hey Pascal,


I see a bunch of CRHTC0638I messages claiming that it matched the rule but when I load the zimport workspace I don't see an associated language definition on the source members (except the ones whose language definition had an extension specified in it that happens to match that source member's extension).


Alex Akilov commented May 21 '15, 8:44 a.m.

 Actually, I ran it again and I do see the 624W message on everything now.  However, the language definitions exist (I see them when I cut and paste the name it claims it didn't find into the system definition search) but they are simply in a different project area from the one I'm importing into.

Your answer


Register or to post your answer.