It's all about the answers!

Ask a question

RTC scm load command error "Unmatched workspace/stream XXXXX"

Vijay Reddy Gaddam (562641) | asked Apr 17 '15, 11:44 a.m.
edited Apr 28 '15, 2:36 a.m. by Ralph Schoon (62.0k33643)

I have the following load rule file for loading the content of component for file specific.
<?xml version="1.0" encoding="UTF-8"?>
<scm:sourceControlLoadRule xmlns:scm="" version="1">
    <component itemId="_Bhoc8DgZEeSKi4jI8QqalA"/>
    <item repositoryPath="/admisanityxps/properties/config/"/>
    <sandboxRelativePath includeRepositoryPath="true"/>
    <component itemId="_Bhoc8DgZEeSKi4jI8QqalA"/>
    <item repositoryPath="/admisanityxps/JavaSource/colruyt/admisanityxps/"/>
    <sandboxRelativePath includeRepositoryPath="true"/>
    <component itemId="_Bhoc8DgZEeSKi4jI8QqalA"/>
    <item repositoryPath="/admisanityxps/JavaSource/colruyt/admisanityxps/"/>
    <sandboxRelativePath includeRepositoryPath="true"/>
When I try to load the repository workspace using the above load rule from shell client then I was able to load the content of the load rule file.

Similarly When I try to load the content of the repository workspace using scm commands I get the following error:
Unmatched workspace/stream "SDP Testing Sample Stream Workspace"

SCM command:
scm load -L /test.loadrule "SDP Testing Sample Stream Workspace" -u xxxx -P Xxxx -r https://rtc/ccm.

I also tried to load the same load rule using the API.
 When I use the Java API i get the following error: Error parsing load rule: cvc-elt.1: Cannot find the declaration of element 'scm:sourceControlLoadRule'.
Snippet used for loading the files from RTC using load rule
File loadRuleFile = new File("C:\\Temp\\test.loadrule");
		System.out.println("LoadRule File: " + loadRuleFile.getCanonicalPath());
System.out.println("Sandbox Location: " + pathlocation);
InputStream ins = new FileInputStream(loadRuleFile);
if (ins != null) {
Reader xmlReader = new InputStreamReader(ins);
ILoadRule2 rule = ILoadRuleFactory.loadRuleFactory.getLoadRule(workspaceConnection, xmlReader, monitor);
ILoadOperation loadOperator = rule.getLoadOp(sandbox, dilemmaHandler, monitor);
monitor.subTask("loading files from RTC server...");;
monitor.subTask("loading files from RTC server completed...");
Version of RTC: 4.0.4

Thanks and Regards,
Vijay Reddy

Vijay Reddy Gaddam commented Apr 20 '15, 4:38 a.m.

One answer

permanent link
Surya Tripathi (65017) | answered Apr 20 '15, 7:24 p.m.
Looks like the line <sandboxrelativepath includeRepositoryPath="true"/> needs to be case sensitive. Try changing it to <sandboxRelativePath includeRepositoryPath="true"/>. Hope that works.

Vijay Reddy Gaddam commented Apr 22 '15, 2:07 a.m. | edited unknown

 Hi Surya,

Thanks for the Feedback. The line <sandboxRelativePath includeRepositoryPath="true"/> What I used was already in the correct format only. In forum I see that the view is not showing the case sensitive as I formated the code. You can view case sensitivity by ccking the Edit option for the quesion. Secondly It is not working.

Vijay Reddy.

Vijay Reddy Gaddam commented Apr 22 '15, 2:07 a.m. | edited Apr 22 '15, 2:10 a.m.

Duplicate comment

Shashikant Padur commented Apr 23 '15, 1:36 a.m.
Can you try couple of things:
1) Run 'scm list workspace -n <your workspace>' to verify that the cli lists that desired workspace.

2) Try loading without using a load rule and see if it works. You could just load only one component: 'scm load -r <repo url> <workspace> <component>'

Vijay Reddy Gaddam commented Apr 28 '15, 1:48 a.m.

 Hi Shashikant,

I'm can see the workspace running the scm command ==> scm list workspace -n 
I also tried to load the workspace also, and able to load the repository workspace content by running scm load command.

Vijay Reddy

Your answer

Register or to post your answer.