It's all about the answers!

Ask a question

lscm command line does not properly acquire locks (iscsi)


Brett Waldo (1101320) | asked Feb 16 '15, 11:54 p.m.
 I read through https://jazz.net/library/article/533 and even posted before on this topic @ https://jazz.net/forum/questions/164481/lscm-scm-command-line-is-very-slow-solved

But I have hit this problem again. It seems RTC lscm does not support file locks properly.  Our homespaces have moved to a new server that has an iSCSI connected hard drive.  While flock works exactly as expected, lscm does not.  While the drive is virtually local, i also tried using it as an NFS mount using the -nolock mount option and still no luck

The end result is lscm does not work. Basically, I can run
lscm show status
lscm show status

The second one will return
Problem running 'show status':
Could not initialize data area. Could not lock /data/home/bwaldo/projects/rtc - locked by other process.

Running pgrep -f rtc shows that multiple daemons get spawned. Typically 5-6 for each call. After a few calls I'll have 30 daemons running (or could run lscm list daemons, would return a slightly smaller set)

Again, flock works just fine. I'm not sure what RTC is doing to not acquire the locks properly.  I can run
lsof .jazz5/.jazzlock and see
java    27578 bwaldo  179uw  REG  253,3        0 5371513730 .jazz5/.jazzlock

So it has the lock, but doesn't really know it and keeps spawning new daemons.  Again, this is an iSCSI device, XFS filesystem.   Note, the config dir is always set to /tmp to avoid any locking issues there.

Would happily provide more information but dont' know what is useful.  

Thanks in advance.


Accepted answer


permanent link
Brett Waldo (1101320) | answered Apr 03 '17, 8:57 a.m.

 The solution was just to not use iSCSI. Not really an answer but easiest path forward in our use case. Getting IBM access to our network was too big of a hurdle for them to troubleshoot.

Ralph Schoon selected this answer as the correct answer

2 other answers



permanent link
Ralph Schoon (59.7k23643) | answered Feb 17 '15, 4:03 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I would suggest to open a PMR with support.

permanent link
waqar shaikh (111) | answered Apr 03 '17, 2:36 a.m.

 Hi Brett Waldo

can you please the answer of this question if you got it.

Your answer


Register or to post your answer.