It's all about the answers!

Ask a question

How do I run repotools in debug mode?


Aaron Cohen (8207751) | asked Oct 28 '07, 8:38 p.m.
JAZZ DEVELOPER
I was following the tutorial on extending jazz with Jazztalk and I got to the section on "How to build a repository" (https://jazz.net/wiki/bin/view/Main/HowToBuildRepositoryDatabase). Now the Junit Script worked however it failed when I added the plugins to repotools. Repotools did not spit out an error but I was missing the expected schema. How do I set repotools to debug mode or verbose output to debug this?

One answer



permanent link
Chris Daly (61651) | answered Oct 29 '07, 2:12 p.m.
JAZZ DEVELOPER
amcohen.us.ibm.com wrote:
I was following the tutorial on extending jazz with Jazztalk and I got
to the section on "How to build a repository"
(https://jazz.net/wiki/bin/view/Main/HowToBuildRepositoryDatabase).
Now the Junit Script worked however it failed when I added the
plugins to repotools. Repotools did not spit out an error but I was
missing the expected schema. How do I set repotools to debug mode or
verbose output to debug this?


There has been some work done post M3 to improve the output from
repotools. See bug 33203:

https://jazzdev.torolab.ibm.com:9443/jazz/service/%7Bdefault%7D/com.ibm.team.repository/itemName/com.ibm.team.workitem.WorkItem/33203

These improvements should be in M4D1, the M4 mid-cycle deployment build
which is due out at the end of this week.

Can you try the scenario again with M4D1 and see if the output helps
identify the problem? I'll be trying it here too and I'll update the
HowToBuildRepositoryDatabase wiki topic based on the changes we see.


Chris

Your answer


Register or to post your answer.