It's all about the answers!

Ask a question

How can I resolve this Configuration Error seen when delivering?


Melissa Kivisto (287220) | asked Dec 09 '14, 8:58 a.m.
I receive the following "Configuration Error" when attempting to deliver changesets:
=============================================================
Problem
The requirements for this precondition are not correctly configured.
Valid 'roles' values are all roles specified in the process

Reason
During Transition, all changes must be approved before being shared with
the team.

The workitem associated with your change set requires one "Approval"
that is approved by an Architect and one that is approved by a Project
Manager.
=============================================================

I have been able to deliver in the past and it does not seem all users are affected.
I have tried removing all the preconditions from the Team Area which owns the stream I am trying to deliver to.

One answer



permanent link
Melissa Kivisto (287220) | answered Dec 09 '14, 9:15 a.m.
Since you are receiving a "Configuration Error", the problem lies in your process configuration, as opposed to failing to meet a required precondition.

In this case, we see the "Reason" we are hitting this error is that there is a precondition for approvals from both Architect and Project manager roles that needs to be checked.
The "Problem" indicates that one of these roles are no longer valid. 
It is likely that since this precondition was created, one of these roles have been removed.

The "During Transition..." sentence indicates that this precondition is being checked for iterations that are of type "Transition", so it is likely that this precondition is only for this iteration type, instead of the whole Project Area or Team Area.  This would explain why not all users seem to be affected by this problem.

Your answer


Register or to post your answer.