It's all about the answers!

Ask a question

What is specific to a Jazz user account that would not allow it to access DOORS modules from RQM via dwa when other accounts can access it on same laptop?


Janet Charbonneau (851640) | asked Aug 08 '14, 2:57 p.m.

We have DOORS Web Access (dwa) set up so that DOORS and RQM can link together requirements and test cases.  It is working properly and two of my coworkers can access a DOORS module from RQM, but I cannot with my Jazz account.  It is not a browser issue.  My coworker can log in via my laptop and it works fine for him.  When I log in, it does not bring up the pop-up to log into DOORS.  I have also tried it on his laptop; it works fine with his Jazz account and not with mine.

To recreate:

Log into RQM.
Browse Test Cases.
Select a Test Case.
Click on Requirement Links.
Click the green plus sign to add a requirement.
Select the DOORS module when it asks for "Artifact Container Selection".
It should bring up a pop-up to log into DOORS web access.  This pop-up comes up when my co-worker is logged in with his Jazz user ID, but it does not work when I am logged into with my Jazz user ID. 

It eventually timed out with this error: 

The following problems occurred during the initialization process: Unable to load /qm/proxy?uri=http%3A%2F%2Fdifjazzdrs.dif.int%3A8080%2Fdwa%2Frm%2Fdiscovery%2Fservice%2Furn%3Arational%3Aers-518d4b5e6be9596a%3A1-518d4b5e6be9596a-M-000033a0%2Fview%3A00000001&dojo.preventCache=1407520909555 status: 400

This is an issue with my Jazz user ID, so is there anything configurable per Jazz user ID that would prevent the DOORS web access pop-up screen to be blocked just from my Jazz user ID and not others?

Accepted answer


permanent link
Maeve OReilly (3813) | answered Aug 08 '14, 4:11 p.m.
 Hi Janet,

that is a weird one.  400 - bad request.   But why only for you!  I would try going to:

https://qm-server:qmport/qm/proxy/logout

Replace with your values.  So clear the jazz proxy of anything 'bad' it may have stored.  

Also try logging into DWA from another tab.

And try a hover over - that will load different data than the new link.  So for a link another user has already created, can you hover over that link to a DOORS requirement and get prompted to login?

Maeve

Janet Charbonneau selected this answer as the correct answer

Comments
Janet Charbonneau commented Aug 08 '14, 4:47 p.m.

Maeve,

For background info, I was able to log into DWA in another tab and when I hovered over an existing requirements link it prompted me to log on to DOORS (web access).  Those were both working when it would not let me create a new link.  Your proxy logout command did fix my problem in the IE browser, so it is now working for me and I can use that if anyone else has this problem!  Thanks! 

It did not work for me in Firefox, version 31.0.  It does now get past a message about logging into DOORS (this is further than I was getting) and brings up a pop-up window that looks like it will show the DOORS log-in screen, but it just says "Loading" and never brings up the log-in screen.

If you have any other suggestions,  please let me know. 

Thank you for at least fixing this in my IE browser!!!

Janet


Maeve OReilly commented Aug 08 '14, 5:33 p.m.

Hi Janet - that firefox issue I actually heard of today and is I believe firefox.  Not personal this time!  I have Firefox ESR 24 and that works.  ESR is what DWA tends to work with, it's very hard to keep up with the regular FF release schedule.  It would be less hard if everything would just keep working but this is life.  


But that the proxy logout fixed it is interesting.  I have not had to use that in a very long time.  What DWA/RQM versions do you have?
 


Janet Charbonneau commented Aug 18 '14, 4:54 p.m.

Hi Maeve,

Sorry for the slow response.  I didn't get an email with your comment and was just coming back to check all of my questions for updates when I saw your response.

We are using RQM 4.0.4 and, I believe, DWA 9.5.1.2.

At least this worked in IE, so I can have this working in one browser if one of my customers runs into this issue as well.

Your answer


Register or to post your answer.