It's all about the answers!

Ask a question

Error SSL_TSL using RQMUrlUtility


sandro de santis (1288) | asked Jul 24 '14, 12:59 p.m.
Trying to create a TestPlan using the Url utility.
I use the following command:
C:\Program Files\Java\jre7\bin>java -jar c:\dati_e_jars\OSLC_RQM\RQMUrlUtility.jar 
    -command PUT 
    -user elvira
    -password elvira
    -context /qm
    -filepath c:\dati_e_jars\OSLC_RQM\TestPlan.txt         
    -url https://localhost:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/Derivat
a1/testplan

And get the following:

                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
                                  <<<<<----- [ RQMUrlUtility ] ---->>>>>
                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Default cookie policy RFC_2109 is used.
RQMUrlUtility: Connected to https://localhost:9443 using project "Derivata1"
Attempting to create SSL_TLS context
java.security.NoSuchAlgorithmException: SSL_TLS SSLContext not available
Unable to create SSL_TLS context, trying SSLv3
RQMUrlUtility: Login error (response code) - 408
Response Body: <html><head><title>Apache Tomcat/7.0.32 - Error report</title><st
yle><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#52
5D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;backgr
ound-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;colo
r:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial
,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,san
s-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-
serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {col
or : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 408 -
The time allowed for the login process has been exceeded. If you wish to continu
e you must either click back twice and re-click the link you requested or close
and re-open your browser</h1><HR size="1" noshade="noshade"><p><b>type</b> Statu
s report</p><p><b>message</b> <u>The time allowed for the login process has been
 exceeded. If you wish to continue you must either click back twice and re-click
 the link you requested or close and re-open your browser</u></p><p><b>descripti
on</b> <u>The client did not produce a request within the time that the server w
as prepared to wait.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/7.0
.32</h3></body></html>
RQMUrlUtility: Timeout authenticating to server for user elvira

I followed the suggestion of the technote:

RQMCopyUtility error: SSL_TLS SSLContext not available. Certificate does not conform to algorithm constraints

by commenting out the line:
#jdk.certpath.disabledAlgorithms=MD2
Windows path to the config file: C:\Program Files\Java\jre7\lib\security

I'd be very grateful for any suggestion.
Thanks in advance


 



Comments
Paul Slauenwhite commented Jul 26 '14, 8:14 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

What RQM server version?  Please try Java 1.6 (see https://jazz.net/wiki/bin/view/Main/RQMURLUtility#Requirements).


Donald Nong commented Jul 27 '14, 8:46 p.m.

Check out the accepted answer in this post and see if you can get more detailed debugging information about the SSL connection.
http://stackoverflow.com/questions/6365209/java-and-ssl-java-security-nosuchalgorithmexception


Donald Nong commented Jul 29 '14, 10:56 p.m.

For the interest of the community, I will share some of my findings with regard to this issue. The tool itself does not appear to be the problem because I have no problems with creating test cases using the exact same version of the tool. The switch from SSL_TLS to SSLv3 may just be an indication of incorrect/non-existent implementation of the SSL protocol on the specific application server (Tomcat/WAS). When the HTTP 408 code appeared, an SSL connection was already established (presumably using SSLv3). The reason for the HTTP 408 code should be the incorrect -context parameter. It should have been "-context qm", not "-context /qm". I can reproduce it by using the exact same parameter. The "time exceeded" error is quite misleading since the error is thrown out immediately.

3 answers



permanent link
sandro de santis (1288) | answered Jul 28 '14, 6:35 a.m.
Thanks for the suggestions.
I am working with the 4.0.4 RQM and RQM Url Utility.

I pointed a 1.6.0 jvm, and now the situation is like this:

>>>>> I inserted a java -version just to be sure
C:\Users\IBM_ADMIN\IBM\RMAddOn-4.0.4.0\jre\bin>java -version
java version "1.6.0"
Java(TM) SE Runtime Environment (build pwi3260sr13fp2-20130424_01(SR13 FP2))
IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Windows 7 x86-32 jvmwi3260sr13fp2-201
30423_146146 (JIT enabled, AOT enabled)
J9VM - 20130423_146146
JIT  - r9_20130108_31100ifx1
GC   - 20121212_AA)
JCL  - 20130419_01

>>>>>>> COMMAND
C:\Users\IBM_ADMIN\IBM\RMAddOn-4.0.4.0\jre\bin>java -jar c:\dati_e_jars\OSLC_RQM
\URL_UTILITY\RQMUrlUtility.jar    
     -command PUT
     -user sandro
     -password sandro
     -context /qm 
     -filepath c:\dati_e_jars\OSLC_RQM\TestPlan.txt                     
     -url https://localhost:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/Derivata1/testplan


>>>>>> RESPONSE

                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
                                  <<<<<----- [ RQMUrlUtility ] ---->>>>>
                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Default cookie policy RFC_2109 is used.
RQMUrlUtility: Connected to https://localhost:9443 using project "Derivata1"
Attempting to create SSL_TLS context

>>>>>> Now the SSL_TLS context has been correctly created, no error messages
>>>>>> BUT, the jazz server response is still the same

RQMUrlUtility: Login error (response code) - 408
Response Body: <html><head><title>Apache Tomcat/7.0.32 - Error report</title><st
yle><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#52
5D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;backgr
ound-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;colo
r:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial
,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,san
s-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-
serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {col
or : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 408 -
The time allowed for the login process has been exceeded. If you wish to continu
e you must either click back twice and re-click the link you requested or close
and re-open your browser</h1><HR size="1" noshade="noshade"><p><b>type</b> Statu
s report</p><p><b>message</b> <u>The time allowed for the login process has been
 exceeded. If you wish to continue you must either click back twice and re-click
 the link you requested or close and re-open your browser</u></p><p><b>descripti
on</b> <u>The client did not produce a request within the time that the server w
as prepared to wait.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/7.0
.32</h3></body></html>
RQMUrlUtility: Timeout authenticating to server for user sandro

Might it be some setup in SERVER.STARTUP is missing or incorrect?


Thank again in advance.

permanent link
Paul Slauenwhite (8.4k12) | answered Jul 28 '14, 7:50 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
If Don's post is not helpful, could you try using the Poster/HTTPRequest plug-ins for Firefox? 

Unfortunately, the RQM URL Utility is not officially supported (see https://jazz.net/wiki/bin/view/Main/RQMURLUtility#Support).

permanent link
sandro de santis (1288) | answered Jul 29 '14, 9:05 a.m.
Thanks for the hint.
I used the Don's suggestion, but finally i decided to use another RQM and URL Utility version.
So I am now using 4.0.6, and i have no problems with the login procedure.
I am getting response 400 to all my requests to create a test plan, but this is out of this thread scope.

Thanks for your help,
Sandro

Your answer


Register or to post your answer.