It's all about the answers!

Ask a question

[closed] Error migrating RTC from 4.0.3 to 5.0 - Cannot Finalise Application Migration


Mike Villis (122) | asked Jul 01 '14, 5:07 a.m.
closed Sep 05 '14, 3:55 a.m. by Ralph Schoon (60.7k33643)
com.ibm.team.repository.common.TeamRepositoryException: CRJAZ2642E The migration cannot continue because the application being migrated is not registered with the Jazz Team Server that is being converted for use as the application database.

Comments
Ralph Schoon commented Jul 01 '14, 5:16 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The initial upgrade/migration failed. The application is no longer registered to the Jazz Team Server. I am not sure why, but that seems to be the root cause as far as one can tell from the error message. There might have been an issue with migrating the team properties file(s), the friends.rdf or something else.

You also want to provide
OS informaion
App Server informaion
Topology informaion

What applications you upgrade (if there are any besides RTC).


Mike Villis commented Jul 01 '14, 5:49 a.m. | edited Sep 05 '14, 6:57 p.m.

Raplh, thanks for the quick response.

In version 4.0.3 there is no rm database as it uses jts. For 5.0 ugrade I have copied the jts database in SQL Server and recreated a new database called rm. All the tables in the databases ccm, qm, dw, jts, rm have been updated in accordance with the Interactive Upgrade Guide

I have copied the teamserver.properties file from JazzTeamServer\server\conf\jts into JazzTeamServer\server\conf\rm as instructed by the guide.

I have got to the point where I am upgrading the Requirements Management Application. The log says that the database tables were added successfully. After that it adds information from RM 4.x's friendsconfig.rdf file into RM 5.x database. After that it connects to rm database which is successful. It then uses ADMIN account to log on to the database at which pont Finalising application migration kicks in.... which is where the error occurs.

Our OS is Windows Server 2012 Standard

64 bit 12 GB RAM

2TB storage

Processor Intel (R) Xeon(R) CPU E5640 @ 2.67GHz  (4 processors)

Domain is Secret, no conenction to Internet, we run Tomcat and use LDAP.

We used RTC 4.0.3 and for version 5.0 we want to use Quality Manager and RTC


Brett Waldo commented Sep 04 '14, 8:37 p.m. | edited Sep 05 '14, 6:56 p.m.

 umm, i know its two months later, but can we bump this thread? I have have had the exact same issue as describe by Mike during two separate RTC upgrades from 4.0.6 -> 5.0.


I'm on Linux (RHEL 6.5)
Oracle 11.2.0
Websphere 8.5.5.2


Ralph Schoon commented Sep 05 '14, 3:55 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Please, either create a new question and provide more data such as your scenario and logs etc. Or rather open a request with support where you can provide a lot more information that can help them to help you to solve this.

In the forums we can only do so much and in complex scenarios we often lack the information needed.

I will close this question, because Mike stated he either get it solved with support or he rolls back. Since he never accepted any answer this question would never be closed otherwise. 

The question has been closed for the following reason: "Problem is not reproducible or outdated" by rschoon Sep 05 '14, 3:55 a.m.

One answer



permanent link
Rohit Balduwa (945311) | answered Jul 01 '14, 5:26 a.m.
Hi Mike

Verify that the server.webapp.url property in the teamserver.properties file for the application points to the public URL of the application. Verify that the Jazz Team Server database being migrated is the correct database with which the application was registered.

Also,please run the diagnostics for JTS,CCM,QM,RM and  paste the complete errors for each.
- What is the database server and application server you using?
- There might be some configuration issue in teamserver.properties file when connecting to the database. Please verify that too.
Any errors you see for JTS , CCM,QM, RM Diagnostics results, paste them.

Comments
Mike Villis commented Jul 01 '14, 6:01 a.m. | edited Sep 05 '14, 6:58 p.m.

Rohit,

When I run repotools-rm.bat there is a step for entering the JDBC location:

<Example //localhost;1433;databaseName=jazz;user=jazzDBuser;password={password};>

Do I put jts or rm in the dtabase name as I have put rm which I assume is correct as the script is configuring the rm database.

Can you confirm if this is correct


Rohit Balduwa commented Jul 01 '14, 6:25 a.m. | edited Sep 05 '14, 6:58 p.m.

Hi Mike

The repository JDBC location will be 'rm' of the rm database.
For the DatawareHouse JDBC location, it will be JTS only.


Mike Villis commented Jul 01 '14, 6:31 a.m. | edited Sep 05 '14, 6:58 p.m.

The script below is taken from the repotoold-rm.bat as I have reached the point in the upgrade where the rm database is being configured. You will see that I am prompted to enter the url path. I entered rm and got all the way to the end of the upgrade and the registration of jazz team server failed.

The teamserver.properties file for rm was updated at the same time I got the failure. It seems that the jts server is not registered why is that and how can I resolve this?

Directory: D:\RTC5\IBM\JazzTeamServer\server
Command:
        repotools-rm.bat -rmUpdateConfigurationFiles oldApplicationHome=D:\IBM\JazzTeamServer\server\conf jts.teamserver.properties=D:\RTC5\IBM\JazzTe
amServer\server\conf\jts\teamserver.properties

Enter [E] to execute this step, [S] to skip it or hit [Enter] to cancel the script execution:
e
Repo Tools
Provisioning using "D:\RTC5\IBM\JazzTeamServer\server\upgrade\rm\..\..\conf\rm\provision_profiles".
  Rational Requirements Composer, Version 5.0 (RMS5.0-I20140509_1428)
  Jazz Foundation - Core Libraries, Version 5.0 (RJF-I20140509-1319)


 To submit questions about issues, go to the Jazz.net forum at https://jazz.net/forum.
 To find more information about a message, see the CLM Messages Information Center at
 
https://jazz.net/help-dev/CLMErrorMessages/index.jsp.
CRJAZ1363I Loading the configuration from "file:conf/rm/teamserver.properties".
Old Application Version is [4.x]
Found configuration file [teamserver.properties] at path [conf/rm/teamserver.properties] (D:\RTC5\IBM\JazzTeamServer\server\conf\rm\teamserver.propert
ies)
This command will take the old JTS server configuration (teamserver.properties) and old RM server configuration (fronting.properties, friendsconfig.rd
f) and create a new RM server teamserver.properties file.
When prompting, values that appear [like this] will be choosen if you hit Enter, or you can enter your own value.
All prompts will be confirmed after you enter a value
CRJAZ1778I This server is configured as an application.
CRJAZ2558I Setting the local server rename state to false and the openServerDescriptionServiceTemporarily state to false.
Found configuration file [jts.teamserver.properties] at path [D:\RTC5\IBM\JazzTeamServer\server\conf\jts\teamserver.properties] (D:\RTC5\IBM\JazzTeamS
erver\server\conf\jts\teamserver.properties)
SET      [com.ibm.team.repository.server.webapp.url] value [https://infrtc001:9443/rm]
SET      [com.ibm.team.repository.server.jts.url] value [https://infrtc001:9443/jts]
Enter JDBC location:
(Example //localhost:1433;databaseName=jazz;user=jazzDBuser;password={password};)

 //infrtc001:1433;databaseName=rm;=sa;password={password};)


Rohit Balduwa commented Jul 01 '14, 6:41 a.m. | edited Sep 05 '14, 6:59 p.m.

Hi Mike

Try referring the below information, there are screenshot's which could be helpful in assisting the rm upgrade.

Migrating the RM application to V5 from V4.x: Tips, common problems, and workarounds:
https://jazz.net/wiki/bin/view/Deployment/RM4to5MigrationTipsTricksProblemsAndSolutions

Running the RM upgrade script for version 5.0:
https://jazz.net/wiki/bin/view/Deployment/RunningTheRMUpgradeScriptForVersion50

If this answers your question please mark it as accepted.

Regards,
Rohit


Mike Villis commented Jul 01 '14, 7:20 a.m. | edited Sep 05 '14, 6:59 p.m.

Rohit,

Thanks for the link... I will follow the instructions and see what happens but from first glance I feel that I have done verything correctly. I will let you know.

Kindest Regards,

Mike


Mike Villis commented Jul 01 '14, 8:35 a.m. | edited Sep 05 '14, 7:00 p.m.

Ronit,

I followed your first link to the letter.... it failed at FinaliseApplicationMigration.

I thought that the ADMIN log in might be the problem as in teamserver.properties this was set to false, haveing set this to true made no difference to the failure I am seeing.

Regards,

Mike

I have a PMR raised with Support 16878,019,866 and awaiting response.


Mike Villis commented Jul 01 '14, 9:17 a.m. | edited Sep 05 '14, 7:00 p.m.

I started clm service and logged on via the web to jts/setup. I ran setup wizard and it completed successfully and finalised the setup. I am not sure if this was the right thing to do but running repotools-rm.bat file still fails at the last hurdle.

I have to get this sorted by today otherwise all the upgrade work I have done todate will be lost as I can't afford to have our server offline for 2 days and we will have revert back to 4.0.3.

 IBM have escalated this issue but to US so I don't think this will be resolved in time.

showing 5 of 7 show 2 more comments