It's all about the answers!

Ask a question

Error saving Work Item. Estimated Value Not Valid.

Renato Mori (10012130) | asked Jun 30 '14, 12:35 p.m.
edited Jun 30 '14, 12:36 p.m.
I installed CLM 4.0.6, and found this that maybe be a bug.
When using Spanish language on browser (IE), when i try to save a work item with an estimated value I'm getting this error message:
The message is in Spanish, but says: The work item couldn't be saved. The Estimated Value is not valid.

I changed, my browser language to English, and the save action worked with the same estimated value.
Anyone know if there's something i missed?, or haven't installed to enable the Spanish language?.

Thanks in advance

3 answers

permanent link
Piotr Aniola (3.7k11638) | answered Jul 01 '14, 3:22 a.m.
What is the actual value you have? Can you show a screenshot of the Estimation field? Please note the values are localized:
"Invalid input. Values must be greater than zero, less than one work year, and adhere to locale-specific formatting for doubles."

permanent link
Rohit Balduwa (945411) | answered Jul 01 '14, 4:28 a.m.
Hi Renato

The error seems to be a defect reported internally 174542: Spanish Translation Error,  and was fixed in CLM3.0.1.1.
Description of this defect:
When you try to put a value like "30d" in estimate field the RTC automatically convert this value to "6 w" using RTC EN (eclipse client). But in Spanish version this value is converted to "6 sem" and "6 sem" is considered a invalid value for RTC validation. So in these conditions are impossible to plan WI if the estimate value >= 1week.

Please confirm if this is the same behavior you encountering for CLM4.0.6.
Confirm the estimate date values and locale settings.


permanent link
Renato Mori (10012130) | answered Jul 01 '14, 12:06 p.m.
More updates about this error. It only happens using the web client. Using rtc eclipse client, worked fine.
I'm attaching some screenshots that hope that help to identify what can be happening.
  • Value and Error message:

  • Language configuration of the IE:

Your answer

Register or to post your answer.