It's all about the answers!

Ask a question

Unable to fetch the rootservice catalog from Rational Doors 9.5


Rahul Singh Bhadauriya (2811720) | asked Jun 13 '14, 12:58 a.m.
Hi,
I have Doors 9.5 Server, Client and DWA (Doors Web Access) configured on my machine.
I am able to access the Doors Web UI now.
As per the documentation the doors is enabled to use the OSLC services.
when i am trying to fetch the rootservice catalog using the url :
http://localhost:8080/dwa/rm/discovery/rootservices
through the rest client in mozilla it gives me an error in response.
"HTTP Status 401 - Inadequate OAuth consumer credentials."
As per the documentation the rootservice doc should be public resource and can be accessible without OAuth authentication.
 

Thanks & Regards,
Rahul

Comments
Robert Kerr commented Apr 01 '15, 6:11 p.m. | edited Apr 01 '15, 6:19 p.m.

I'm having the same issue as Rahul:  DOORS 9.5.2 working well.  Web Access working correctly.  Accessing http://localhost:8080/dwa/public/rootservices
gives me "The configuration is invalid".

Was a solution ever found for this?

Thanks

3 answers



permanent link
Eric Jodet (6.3k597120) | answered Jun 13 '14, 2:08 a.m.
JAZZ DEVELOPER
 Hello Rahul,
you're right - the rooservices document should be accessible.

Please check your DOORS configuration:
https://www.ibm.com/developerworks/community/blogs/SrinivasMandava/entry/configuring_ibm_rational_doors_and_dwa_to_consume_and_provide_oslc_services_from_to_rtc17?lang=en

Eric

permanent link
Maeve OReilly (3813) | answered Jun 13 '14, 7:45 a.m.
Hi Rahul,

That is the wrong URL for 9.5.  Use http://localhost:8080/dwa/public/rootservices

Note that if you trying to integrate with a Jazz product on https, the fact you have DWA on http will cause you problems (browsers are blocking mixed http/https content).

9.6 is out of the box on SSL but it's not hard to configure in 9.5.   http://pic.dhe.ibm.com/infocenter/doorshlp/v9r5m2/topic/com.ibm.rational.dwa.install.doc/topics/t_configureSSL.html  

Maeve




Comments
Rahul Singh Bhadauriya commented Jun 16 '14, 9:21 a.m.

Hi Maeve,
Thanks for your answer!
I have followed link to configure the Doors server in secure mode (SSL), but in both the cases (SSL and without SSL) it's giving me the same error while querying on the mentioned URI of rootservices as follows using REST Client.
<?xml version="1.0"?>
<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:oslc="http://open-services.net/ns/core#">;
<oslc:Error>
<oslc:message>The configuration is invalid</oslc:message>
<oslc:statusCode>500</oslc:statusCode>
</oslc:Error>
</rdf:RDF>

Any pointers regarding this issue ?

-Rahul


Maeve OReilly commented Jun 16 '14, 11:17 a.m.
Hi Rahul,
I would check it directly in firefox, just rule out any issue with the GET re. Headers.  I don't know if they can interfere, but FF should be able render it without the need for any addons.  

The rootservices is generated. It'll be read from what is set on the database using the dbadmin commands and what is in the festival.xml.  If you paste the contents of your festival.xml I can check that. It has changed over the releases, make sure you are following instructions for the exact version of DWA you are using.  9.5.0 and 9.5.1 are not the same w.r.t. configuring the festival.xml.


I would also verify all the dbadmin settings again - run them and make sure each parameter gives a line saying for example 'dwaHost is set'.   For 9.5.2 http://pic.dhe.ibm.com/infocenter/doorshlp/v9r5m2/topic/com.ibm.rational.dwa.install.doc/topics/t_setupddbs.html
Maeve


Rahul Singh Bhadauriya commented Jun 17 '14, 9:33 a.m. | edited Apr 01 '15, 6:20 p.m.

Hi Maeve,
Please find the festival.xml file as follows:

<?xml version="1.0" encoding="UTF-8"?>
<!-- Licensed Materials - Property of IBM - some unique copyrights (i.e., the ability to copy,  modify,  distribute) may be licensed in certain circumstances (e.g., sample/template code  intended to be used by
customers to build upon and distribute as their own products).
%full_filespec:festival.xml~8.1.3:xml:VBS#1 %
(c) Copyright IBM Corporation 2007, 2009. All Rights Reserved.
 U.S. Government Users Restricted Rights: Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.-->
<f:configuration instanceId="c4402682-3e61-43b1-a43f-93437ef230ca" xmlns="http://www.telelogic.com/festival/1.0" xmlns:f="http://www.telelogic.com/festival/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">;
 <f:lsc><!-- Brokers we know about --><f:endpoints>
<f:broker name="GENERALSERVICES" password="" url="tcp://<DWA HOST>:61616?wireFormat.tcpNoDelayEnabled=true&amp;wireFormat.maxInactivityDuration=0" username=""/>
<f:broker name="DCSERVICES" password="" url="tcp://<DWA HOST>:61616?wireFormat.tcpNoDelayEnabled=true&amp;wireFormat.maxInactivityDuration=0" username=""/>
<f:broker name="RMSERVICES" password="" url="tcp://<DWA HOST>:61616?wireFormat.tcpNoDelayEnabled=true&amp;wireFormat.maxInactivityDuration=0" username=""/>     
</f:endpoints>
<!-- Mapping from Repository IDs to the broker we use to reach the repository -->
<!-- The repositoryUrn must be replaced with your database unique identifier. -->
<!-- An example repository urn is:     urn:rational:ers-46dd5d7806b96973:     -->
<!-- Note the trailing colon ':' after the 16 digit id.                       -->
<!-- Please see the documentation describing how to obtain the correct value. -->
<f:mappings>
<f:repository-mapping enabled="true" endpoint="RMSERVICES" name="DOORS ERS Repository" repositoryUrn="urn:rational:ers-5062b3db673434a8:"/>
</f:mappings>
<!-- Configurable system properties -->
<f:properties>
<f:property name="licence.server.location" value="<DOORS Server HOST>"/>
<f:property name="published.url.prefix" value="https:// <DWA HOST>:8443/doors/redirector/"/>
<f:property name="ForceHttpsForAuthenticationForOAuth" value="true"/>
<f:property name="ForceOAuthForOslcResource" value="false" />
<f:property name="oauth.domain" value="https:// <DWA HOST> :8443/dwa"/>
</f:properties>
<!--  The TRS compact base set schedule and configuration options        -->
<!--  If TRS is disabled than these configuration options are ignored.   -->
<!--  The time is in 24 hour format.                                     -->
<!--  The day_of_week values match the java.util.Calendar values.        -->
<!--  Sunday=1, Monday=2, etc                                            -->
<f:trs>
<f:compact-base-set>
<f:schedule><f:compact-event day_of_week="7" time="10:00"/></f:schedule></f:compact-base-set>
</f:trs>
</f:lsc>
</f:configuration> -Rahul


Maeve OReilly commented Jun 17 '14, 11:27 a.m.

It's full of spaces and weird characters.  that might be from cut-paste, but if not, they'll break something.

The license.server.location is missing a port.
The published.url.prefix and oauth.domain are necessary in versions Older than 9.5.1.  From 9.5.1 onwards they should not be set.  
You might be quicker logging a PMR on this.   


permanent link
Robert Kerr (11) | answered Apr 02 '15, 12:07 p.m.
Finally figured out what was going wrong with my installation.  Specifically, when I ran the:

dbadmin -dcnEnable. . .

command, I forgot to put a hyphen in front of dwahost command.  Once I re-ran it with the hyphen, I was able to query the rootservices page and get the right response.

Your answer


Register or to post your answer.