It's all about the answers!

Ask a question

RRC - How can I update artefacts between 2 geographically separate repositories?

Steven Witty (736) | asked Jun 02 '14, 7:28 a.m.

Hi, I'm not sure if what I need is possible, but asking can't hurt, as I may get a prod in a better direction. Apologies if this seems complicated, and I am not precious if someone points that out and simplifies it for me :)

I have 2 separate RRC Repositories in 2 different countries. I can not connect them to each other. As it stands, the situation is as follows:

Repository 1 - Holds the Master Set of Requirements, all Functional or Non Functional, standard 1 or 2 line requirements. Have a number of custom attributes I've set up. I want to add Use Case Modules from Rep2 to this, but this repository is my main working one for client satisfaction.

Repository 2 - Holds the Master set of Use Cases. These are created using Modules (Requirement Specification type), and a module includes the normal stuff you'd expect to see in one of these, i.e. Description, Flows, Conditions, Business Activity Diagrams and Use Case Diagrams. These look great, but I can't get them out of this repository! (See below)

What I need is for the Requirement Specification (Use Case) Modules, which I consider to be "normal" looking Use Cases, with all their elements in, to be able to be exported from Rep2, imported to Rep 1, wherein I link them to my Func and Non Func Requirements. I will then be able to allow the Test Manager to base his scripts on the Modules. Obviously this will include traceability and links between the Modules, Requirements and subsequent testing.

The idea is, if any of the Use Cases in Rep2 get updated, they can email me an export, which I can import to Rep1, and it replaces the previous version. Ideally this will work the other way, so if my requirements are updated, I can send them the new versions which they can then import. All of this, hopefully, can retain the existing links.

I've tried ReqIF, but that just doesn't seem to work. I can't see the artefacts I add in the export I prepare, then when I hit save, I just get a non stop "loading" message. Nothing happens, so I can't seem to export this way.

I've tried creating a "Create and Print" but that also fails, with a Error 500: Internal Server Error.

Am I trying to do something impossible? Is it likely a configuration issue and I should be able to do what I'm trying? Am I way off track and doing something silly? Any advice/comments are welcome! Im on RRC 4.0.6.

Mike Jaworski commented Jun 04 '14, 12:06 p.m.


Could you provide the logs for the 500 error you see during create and print and/or the ReqIF export? It sounds like you may have some module data with some incorrect references, as this is the likely cause of both Create and Print AND ReqIF export failing. Thanks,


Steven Witty commented Jun 05 '14, 3:08 a.m.

Mike, the 500 error has gone now. My Sys Admin did a reinitialisation of the RRC Print module and hey presto...printing and document production works, which is of course great news. I Know, if in doubt...reboot :)

The ReqIF issue a little more interesting though. It's still the same for me, i.e. I create a definition, I add artifacts to it, I click save and I just get a "Loading..." in the main pane I would expect to see a list of added artifacts. However, if I right click the name and choose "Export", it actually works just fine. Export works, and I can then import it to the other repository, everything is inside it as expected. I just can't see what's in it when I create it.

Luckily this meant I could test both approaches out, and ReqIF is absolutely fine for what I need, and its working, sort of, so for the moment I appear to be ok.

Kind regards


Accepted answer

permanent link
Mike Jaworski (1.4k6) | answered Jun 05 '14, 8:01 a.m.

I was initially thinking that this sounded similar to an RRC defect which was fixed in 4.0.6 (ReqIF: Unable to Save New Definition when > 1400 artifacts (79657)), but in that case that ReqIF package wasn't actually complete, so I would have expected your ReqIF to fail on re-import. But if it's working for you, that's great!

I'm wondering now if this continuous Loading prompt might be an effect of the browser you are using. Are you by chance using IE? If so, what version? I did a quick search and it looks like there was a defect reported against RRC 4.0.6 using IE10 where very similar behavior was seen:

The temporary workaround would be to view the list of artifacts in FF or Chrome, where the list should be visible. Long term solution would be to upgrade to RDNG 5.0 (replacing RRC starting in 5.0), which actually just recently released!

Hope this helps!
Steven Witty selected this answer as the correct answer

Steven Witty commented Jun 05 '14, 8:49 a.m.

Hi Mike,

When will I ever learn...IE9. I just logged in to my RRC using Chrome, and voila, ReqIF displays the artifacts as you'd expect.

We're running 4.0.6 at the moment, are you suggesting that the next update for RRC will be to RDNG5.0?? So we've gone from DOORS+ReqPro to RRC and we're now going back to DOORS?? I'm only just getting to grips with RRC dammit! :)

Thanks for the pointer about IE. I'll just use Chrome I think.

Mike Jaworski commented Jun 05 '14, 9:41 a.m.

Hahahaha No worries Steven! RDNG is actually still RRC under the covers, so if you're already used to RRC then the learning curve to adopt DNG should be essentially seamless. I think the naming change was an internal decision since DOORS has been around for longer, so it has a lot more "street cred" than RRC :-)

As far as next version goes, I know the plan is to release a 4.0.7 version in a couple months as an ESR (Extended Support Release) with continuous iFix releases, but as far as I can tell the 84841 defect I mentioned is not planned for 4.0.7 - only for 5.0. If you have any concerns about this, feel free to contact Rational Support.


One other answer

permanent link
Gabriel Ruelas (1.1k13) | answered Jun 02 '14, 8:13 a.m.
Hi, ReqIf should be working, if that is not tthe case, I suggest to contact IBM support. Here is the link: and here is a link about Rational Support

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.