It's all about the answers!

Ask a question

Extension attributeValueProvides only shows Generic


Prakash Behrani (28510) | asked May 12 '14, 3:08 p.m.

I am trying to create an extention using a Plug-in development project.

Have set dependencies on

com.ibm.team.workitem.common
com.ibm.team.repository.common
com.ibm.team.process.service
com.ibm.team.reports.workitem.service
com.ibm.team.process.common
com.ibm.team.repository.service
org.eclipse.core.runtime

In the Extensions tab, specifed extention:

com.ibm.team.workitem.common.attributeValueProviders

On right-clicking the extension and selecting New option, I only see "Generic".  I was expecting to see defaultValueProvier, ValueProvider etc.

I would appreciate if someone could point out what I may be missing.

I am using SDK 4.0.2.  I tried following steps in RTC 4.0 Extensibity workshop for setting up SDK as follows:

1) Downloaded RTC-SDK on server and unzipped the package.  

2) Then as provided in a RTC 4 extensibility workshop, I go through the following steps to set up SDK environment.
a) start eclipse client.
b) From Windows->Preferences, General->Workspace, switch Text file encoding to UTF 8.
c) Create a new target platform from preferences Plug-in Development->Target Platform.
d) In the New Target Definition wizard, select Nothing: Start with an empty target
definition and then click Next.
e) On the second page of the wizard, enter RTC SDK as the Name and click Add...
f) In the Add Content wizard, select Installation and then click Next.
g) On the second page of the wizard, enter D:\Program Files\IBM\rtc-sdk as the Location and then click Finish.
h) After the operation completes, click Finish in the New Target Definition wizard.
i) Back on the Preferences dialog, select the new Target Definition (RTC-SDK) and then click OK.
j) switch to Plug-in development perspective.
k) On the left, select the Plug-ins view.
l) From the view's context menu click Select > All.
m) From the view's context menu select Add to Java Search.

3) Create a new Plug-in project
a) On the first dialog, provided a name for the project. Click Next.
b) Removed the check-box for an Activator.
c) Clicked Finish to complete creating the project.

Thanks.

2 answers



permanent link
Ralph Schoon (56.5k23642) | answered May 13 '14, 3:29 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Please have a look at https://rsjazz.wordpress.com/2013/06/26/attribute-customization-java-based-value-providers-conditions-and-validators/
I apparently did not have your problem. I think I developed for RTC 4.0.3.

To set up your development I would recommend to follow https://rsjazz.wordpress.com/2013/02/28/setting-up-rational-team-concert-for-api-development/ and run the Extensions Workshop: https://jazz.net/library/article/1000

This makes sure you have a working SDK setup, including licenses and UTF-8 settings.

permanent link
Prakash Behrani (28510) | answered May 19 '14, 1:04 p.m.

I tried the same steps with SDK 4.0.5 and was able to see the expected options.

Which leads me to beileve that SDK 4.0.2 was the issue.

Your answer


Register or to post your answer.