It's all about the answers!

Ask a question

Component not visible to other users


Ketan Divecha (26812) | asked Dec 02 '13, 3:59 p.m.
retagged Dec 16 '13, 11:46 a.m. by David Lafreniere (4.6k7)
Hi,

I have an urgent issue I need help with. I migrated a subversion repo to RTC recently, everything went normal, no error messages etc. I am even able to create/load the workspace. However other users are not able to load/see the same component. We have the same roles/permissions etc. How do i fix this ?


2 answers



permanent link
Ralph Schoon (59.4k23642) | answered Dec 02 '13, 4:11 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Check the visibility and ownership on the component. If it is owned by you and only privately visible, others can't see it. Make it owned by the team/project and they can.

Comments
Ketan Divecha commented Dec 02 '13, 4:15 p.m.

that's the first thing i checked, the stream and component are owned by a team area, and visibility is team private, and all the users are members of the team area. 


permanent link
Kevin Ramer (4.5k6171189) | answered Dec 02 '13, 4:11 p.m.
There are a couple of reasons this may happen (assuming you delivered to some stream, components)

  1. The "My filter" of the Jazz Administration view is filtering data.   In that view there is an icon 2nd from the left ( a bold yellow arrow between two smaller blueish ones).  Pick that menu and look at what's checked in "My Filter"
  2. Someone has changed ownership of the component or it is owned by you.   If components are owned by a person they will not be visible.   Right click on a component, choose Open.  Ownership should be a Project or Team Area

Hope that gives you clue(s).

Comments
Ketan Divecha commented Dec 02 '13, 4:32 p.m.

I checked all those things, others have had the same problem https://jazz.net/forum/questions/86951/components-not-visible-in-a-stream

Your answer


Register or to post your answer.