It's all about the answers!

Ask a question

snapshots created by scm missing CRJAZ0215E


K M (38324549) | asked Nov 20 '13, 5:41 p.m.
retagged Dec 16 '13, 5:48 p.m. by David Lafreniere (4.7k7)
I create a snapshot using the SCM commands the owner of the snapshot is a workspace, everything works no errors.
After 2 or 3 days some of the snapshot disappear. We are going to try reindexing to see if they come back.

I get this error when searching for the snapshot, or when showing snapshots in a workspace.

CRJAZ0215E The following record was not found in the database: com.ibm.team.scm.common.internal.impl.BaselineSetHandleImpl@4d1e4d1e (stateId: [UUID _VrhshjG3EeOYD7vNmexgqw], itemId: [UUID _VreCEzG3EeOYD7vNmexgqw], origin: <unset>, immutable: <unset>)

RTC4 and RTC3           scm version 3

Why is this happening, snapshots create by Java api have no problem.


Comments
Shashikant Padur commented Nov 20 '13, 10:30 p.m.
JAZZ DEVELOPER

I am assuming you tried to the list the snapshots using the scm command line. Can you list the snapshots using the Eclipse client?

3 answers



permanent link
Don Yang (7.4k2195130) | answered Nov 20 '13, 6:38 p.m.
We see some cases that restarting server/and DB server would fix this kind of error.
If that does not help, verifying DB inconsistency can be the next approach by using onlineverify tool:
https://jazz.net/wiki/bin/view/Main/L3DevTool

If you get onlineverify.log file and it does indicate any errors, you may want to contact support to further investigate.


permanent link
K M (38324549) | answered Nov 21 '13, 7:09 a.m.
Listing the snapshots with scm and eclipse gui reports the same error.



permanent link
Sian O'Briain (35319) | answered May 15 '15, 11:48 a.m.
Hi wondering if this was resolved?

Comments
K M commented May 15 '15, 12:21 p.m.

Never fixed, and gave up on this rtc instance.

Created five new 407 server instances, they seem to work ok.


Sian O'Briain commented May 15 '15, 12:34 p.m.

thanks for the reply

Your answer


Register or to post your answer.