It's all about the answers!

Ask a question

Some questions on Work Item management


T M (8876186143) | asked Feb 19 '09, 12:31 p.m.
Hi,

Some questions on WI:

1) I don't see "Newly Assigned Work" in the My Work View?

2) Why is a "tag" field required?

3) comment 5, and attachment 982 - These quick links not working!

4) Why "Simple Query" and "Full Text Query" provided when the same can be achieved through "Start from Scratch" query?

5) From the help: "You can also enter text in the same entry field. The matching work items appear in the results table. The value in the Score column indicates how likely it is that the work item matches the text specified in the query."

<Theju> Not working. Searches only in the Summary field and that too for a full word.

6) The Work Item editor returns work items that contain similar text as the current work item.

<Theju> This works only in the summary field.

7) "To configure a small pop-up alert:
Click Window > Preferences. Expand General and select Notifications.
Under Feeds, select Batch of Items Received or Item Received. Specify the conditions under which you should receive an alert. Select the type of alert."

<Theju> What is Batch of Items Received or Item Received??

8) Recent Work section in Team Central is not getting updated! Is this a bug?

9) How to use alias? Looks like alias is not working!

2 answers



permanent link
Patrick Streule (4.9k21) | answered Feb 19 '09, 4:58 p.m.
JAZZ DEVELOPER
1) I don't see "Newly Assigned Work" in the My Work View?

Do you have multiple project areas? Are you connected to the right one?

2) Why is a "tag" field required?

We don't require 'Tags' in our process templates, so your project is
explicitly configured this way.

3) comment 5, and attachment 982 - These quick links not working!

Are the links not detected as links or are the links not opening the
attachment or jumping to the comment when clicking on them? Are they not
working for these specific numbers or in general?

4) Why "Simple Query" and "Full Text Query"
provided when the same can be achieved through "Start from
Scratch" query?

Because we tried to provide short-cuts to frequently used combinations of
conditions. There was some discussion around whether this is actually
useful or not.

5) From the help: "You can also enter text in the same entry
field. The matching work items appear in the results table. The value
in the Score column indicates how likely it is that the work item
matches the text specified in the query."

Theju> Not working. Searches only in the Summary field and that
too for a full word.

The full text search does not only search the summary field. Dou you have
an example where you think it was only looking in the summary?

6) The Work Item editor returns work items that contain similar text
as the current work item.

Theju> This works only in the summary field.

No, this takes other fields into account as well, although the weight of
the summary contents may be higher than for other fields.

8) Recent Work section in Team Central is not getting updated! Is this
a bug?

Did you use the 'Start working', 'Stop working' actions? The recent work
section refers to the history of 'Current Work Items'.

9) How to use alias? Looks like alias is not working!

Do you have some steps that describe what you consider as not working? I
assume you configured an alias like 'todo' for a work item type and when
you typed 'todo 2435' in e.g. a work item comment it was not detected?

--
Regards,
Patrick
Jazz Work Item Team

permanent link
T M (8876186143) | answered Feb 20 '09, 5:31 a.m.
Hi Patrick,

Thanks for your post!

1) I don't see "Newly Assigned Work" in the My Work View?

Do you have multiple project areas? Are you connected to the right one?

<Theju> I have connected to the right project area. The "New Unassigned Work Items" section is configured to run "New Unassigned" query. If I manually run this query I see all the unassigned WIs but through in this section there is no output. I tried refreshing many times but no luck. I'm using RTC 1.0.1.

3) comment 5, and attachment 982 - These quick links not working!

Are the links not detected as links or are the links not opening the
attachment or jumping to the comment when clicking on them? Are they not
working for these specific numbers or in general?

<Theju> I can see the links. No issues. But how do I get a comment number? I can see the attachment number but where do I see the comment number to reference it in the link?


6) The Work Item editor returns work items that contain similar text
as the current work item.

Theju> This works only in the summary field.

No, this takes other fields into account as well, although the weight of
the summary contents may be higher than for other fields.

<Theju> To reproduce the problem: Create a WI with a word say "Zodiac" in the description field. Create a "Full Text Query" and search for the string "Zod". The query doesn't return anything. Then put "Zodiac" in the Summary field and run the same query with the same search string ("Zod"). You see the query result returning this WI.

8) Recent Work section in Team Central is not getting updated! Is this
a bug?

Did you use the 'Start working', 'Stop working' actions? The recent work
section refers to the history of 'Current Work Items'.

<Theju> As mentioned in the help: "You can also use the Recent Work section in the Team Central view to see work items that you have worked on recently". I was expecting that any WI that I change the state should appear in this section. Yes, I see WIs in the "Recent Work" section after I do a "start working" followed by a "stop working" actions but why for only "start working" and "Stop working" actions?

Your answer


Register or to post your answer.