It's all about the answers!

Ask a question

RTC error after advisor deployment CRJAZ1112I

Dimitrios Dentsas (7348) | asked Oct 25 '13, 11:24 a.m.
edited Nov 04 '13, 6:26 p.m. by Stephanie Taylor (24115)
I'm having the exact same problem that was discussed in this thread:

It was caused like this:
  1. Deploy the advisor extension plugin by copying the .ini-file to server\conf\ccm\provision_profiles and adding my site-folder in \server\conf\ccm\sites\
  2. Request server reset with this URL: <host>/ccm/admin?
  3. Advisor plugin couldn't deploy properly for some reason
  4. Delete all files that were added in point 1.
  5. Restart WebSphere
  6. CCM does not deploy.
I got CCM working again with a freak accident. I still had the server reset url open in my Firefox tab. I clicked it even though I couldn't access anything inside CCM. It told me that the following file was missing:


I just copied the built-on.txt file from the jts.war\ folder to the ccm.war\ folder and clicked again on the "Request Server Reset" button. After restarting WebSphere once again it worked all of a sudden.

My observations:
It seems that all it really needed to work again was a fresh server restart request. But since you can't reach the server request button it is effectively a deadlock situation (or can you skip this step after providing the built-on.txt?).

Isn't there a way to request a server restart for ccm without having to access ccm directly?

Ralph Schoon commented Oct 25 '13, 1:49 p.m.

The Built-on.txt is the file that gets deleted if you request a server reset.After restarting the server, the redeployment happens. So it might have been deleted due to the reset request already.
Not sure what causes your issues. Sometimes removing WAS caches helps.

One answer

permanent link
Diana Millan (1112) | answered Apr 30 '15, 12:59 p.m.
The same situation happens to me, in a Tomcat installation. It finally get solved deleting the plugin files and registering again the CCM application using the "Registered Applications" menu on the server administration page "jts/admin/".

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.