It's all about the answers!

Ask a question

RTC 4.0.4 zOS bfagent package by work item - unable to see selected item members - why?


Donald Poulin (2249114107) | asked Oct 17 '13, 8:11 a.m.
edited Oct 21 '13, 5:46 p.m. by Millard Ellingsworth (2.5k12431)
I have successfully delivered changes to a stream (associated with a work item) and have successfully created a subset id based on that work item and executed a build based on the subset id successfully. I have also been able to successfully promote that changeset and binary  based on work item. I created a package definition against both the 'development" stream where the member was originally built and also against the "qa" stream which was the target of the promote. In both cases a package by work item request fails due to "nothing to package". Also  in both cases after selecting the specific work item there is no visible list of members showing in the "Work Item Summary" page. I tried a package by shiplist and that appeard to work ok except two odd things - 1) the package summary shows the correct member but there is no "last modified time" value and 2) the package manifest also  does not show a last modified time - rather it shows:

<?xml version="1.0"?>
<manifest type="MANIFEST_LIST">
   <container name="RMAC05.AGILETST.QA.LOAD" type="PDS">
      <resource name="HELLOASM" type="PDSMember" lastModifiedTimestamp= "ZLM4DATE ZLMTIME:ZLMSEC"/>
   </container>
</manifest>

I am  using the RTC 4.0.4 eclipse client basedon eclipse 4.2 along with RDz 9.0 client.

An update the manifest above is for an ASM program. When I ran by ship list with two Cobol programs the package manifest showed last modified time correctly. So must be something in the assemble options? 

One answer



permanent link
Kevin Doyle (60425) | answered Nov 21 '13, 1:20 a.m.
JAZZ DEVELOPER
Hi Donald,

If you are still experiencing this issue I recommend you open a PMR to investigate it further.  Remember with work item packaging if a build of a member is done at the level you are packaging in another work item, then the original work item won't have any outputs associated with it for that member anymore.  By trying QA it sounds like you would of been trying the same level as was done in the promotion unless something went wrong during the promotion.

Scenario 1:  Make changes and associate to Work Item A.

Build -> Promotion -> Package (From Dev or QA build definition)

This will work.

Scenario 2: Make changes and associate to Work Item A.

Build -> Promotion -> Make changes to same members as was in Work Item A -> Build -> Package (Dev)

Package won't find any outputs for Work Item A anymore.  If you Package from QA it will find outputs.

Thanks,
Kevin

Your answer


Register or to post your answer.