It's all about the answers!

Ask a question

RTC 4.0.4 Tomcat7 Windows 7 as a service won't start


Donald Poulin (2249118107) | asked Oct 02 '13, 4:06 p.m.
edited Oct 02 '13, 4:17 p.m.
Just upgraded RTC 4.0.3 under windows 7 to RTC 4.0.4. We were previously running tomcat as a service with RTC 4.0.3. We ran through the upgrade steps very carefully, including the steps to "replace" the 4.0.3 tomcat service setup with the 4.0.4 tomcat service setup. Now when we try to start the service it stays in a stopped state and we really see no errors. We can start up RTC 4.0.4 successfully and all looks good but we can't start up the tomcat service.

Here is what we see in the tomcat7.stderr

2013-10-02 12:04:21 Commons Daemon procrun stderr initialized
Unrecognized option: -Xgcpolicy:gencon

2013-10-02 12:05:02 Commons Daemon procrun stderr initialized
Unrecognized option: -Xgcpolicy:gencon

2013-10-02 12:06:01 Commons Daemon procrun stderr initialized
Unrecognized option: -Xgcpolicy:gencon

2013-10-02 12:18:52 Commons Daemon procrun stderr initialized
Unrecognized option: -Xgcpolicy:gencon

2013-10-02 12:22:06 Commons Daemon procrun stderr initialized
Unrecognized option: -Xgcpolicy:genc

Would appreciate any help we can get.

3 answers



permanent link
Donald Nong (14.4k314) | answered Oct 03 '13, 12:50 a.m.
If the error message can be trusted, the Tomcat service picks up the incorrect JVM when it starts up. -Xgcpolicy:genconis for IBM Java while -Xgc:gencon is for Oracle Sun Java.

Comments
Donald Poulin commented Oct 03 '13, 7:48 a.m.

If I remember correctly those parms are set when you run the tomcat7w.exe to set up the service and the actual startup  command on the "General" tab comes up greyed out.  So what file and where would you change to "gencon" to "genconis"?


Kot T. commented Oct 03 '13, 10:09 a.m.
JAZZ DEVELOPER

Is the Java Virtual Machine path set to the jvm.dll in the JazzTeamServer directory?

...\JazzTeamServer\server\jre\bin\j9vm\jvm.dll


permanent link
Zeeshan Choudhry (6541512) | answered Oct 04 '13, 5:45 a.m.
Post all your JAVA tab options in tomcat7w.exe
Looks like a configuration issue of JAVA parameters and selecting the right JVM.

permanent link
Karl Weinert (2.0k52736) | answered Oct 04 '13, 10:52 a.m.
JAZZ DEVELOPER
It sounds like you may *not* have switched the default JVM to the one included with the CLM install.
( I can reproduce your error by using the default jvm which on my system is a 32 bit version of the Sun\Oracle jvm)

To fix it open tomcat7w.exe, switch to the java tab and deselect the "use default box". Then manually set the full path to the jvm that Kot mentioned in her comment. (...\JazzTeamServer\server\jre\bin\j9vm\jvm.dll )
With that setting you should stick with -Xgcpolicy:gencon
If the start button is grayed out make sure tomcat.exe is not running in task manager with "show processes from all users" selected
Then restart tomcat7w.exe (grayed out usually means that the tomcat service is in a funky state)









Comments
Donald Poulin commented Oct 04 '13, 12:31 p.m.




Here is the image and all looks totally correct - unless we need to change to use genconis instead of gencon


Karl Weinert commented Oct 04 '13, 12:47 p.m.
JAZZ DEVELOPER

It looks like you are pointing to a 32 bit JVM which is likely to be an Oracle one.
Note: It is pointing to  Program Files (X86)

Based on the class path it appears you want to use the following in the top field right under "Java Virtual Machine"
C:\Program Files\IBM\JazzTeamServer_404\server\jre\bin\j9vm\jvm.dll

I also see that you have semicolon separated paths in that field.
(...\client\jvm.dll;c:\program files...)
You will want to have a single path to the jvm.dll as described above.

genconis was a typo it was meant to say gencon is for IBM..
The difference was the -X setting. IBM uses -Xgcpolicy Oracle uses -Xgc

Your answer


Register or to post your answer.