It's all about the answers!

Ask a question

Folders outside Eclipse - cannot get under Jazz source control


G H (144) | asked Sep 10 '13, 6:51 a.m.
Using a fresh install of RTC 4.0.1 for Mac. I'm using Eclipse client but don't want Eclipse projects - just to control files in another folder.

I have followed https://jazz.net/library/article/192#LoadFolderOutside and https://jazz.net/library/article/531/ without success. Drag and drop into Project Explorer doesn't appear to work on a Mac.

All I have managed to do is create a stream, a repo workspace and a component. The component is listed in the Components folder but not shown "under" the repo workspace. The workspace says loaded but there are no files in it.
If I try to load the repo workspace. I just get a blank window (i.e. no file structure is shown) and the message, "No items are selected to be loaded however the repository workspace will still be shown in the Pending Changes view."

What's going wrong?

4 answers



permanent link
Christian Morgan (317612) | answered Sep 10 '13, 10:58 a.m.
Ok, I think I see the issue now.  In order to add files to a component, you need to load the repository workspace to a local sandbox.  Best approach would be to unload the repo wksp from pending changes view or the My Repository Workspaces folder in the Team Artifacts view, then Load it, choose the 3rd option "Browse the components...." -- deselect and select the component, ensure under Advanced that you have a local sandbox location specified.  For the 3 Advanced options concerning the eclipse project, choose whichever you need to, but per my previous post, I always leave the default "Load and create eclipse projects...." and just ignore (a right click context menu option on files you don't want to place under version control or have pending changes track) the .project file that is created.  However if you choose the 3rd option "Load the selected folders but do not...." just remember that you will not be able to interact with the file system directly through the Java perspective, you'll have to use external tools to manipulate the files but using the refresh pending changes option for the local sandbox you can have pending changes track and perform the check in and deliver/accept operations....

Comments
G H commented Sep 10 '13, 11:17 a.m.

 Yes, I actually want to only interact with the files outside of Eclipse and use a different editor so I'll be going with the 3rd option - once I fix this :)


Anyway, as per your instructions, I unloaded the repo workspace. Message was - You don't have a repository workspace loaded.
All good.

I then right-clicked the RW and choseLoad...

I see a dialog box, Repository Folders to Load. There are no folders/files in the white box underneath and no way of accessing the file system. See screenshot.

 


Tim Mok commented Sep 10 '13, 11:32 a.m.
JAZZ DEVELOPER

I agree and would follow the instructions for loading the component root in the first article linked in the question. Adding to that folder would be picked up when you perform the refresh.

Also, the command line is another option unless you don't want to deal with typing.


G H commented Sep 10 '13, 11:39 a.m.

Tim, as I stated above, I have followed those instructions but unfortunately they do not help in my case.

You can see the difference in my screenshot from the one in the article. Mine has no folders to select, therefore I cannot add anything to the component or workspace.

I don't mind typing - what command line are you thinking of?


Tim Mok commented Sep 11 '13, 9:19 a.m.
JAZZ DEVELOPER

The command line client. It's included in the full client zip or as a separate download in the download section.

The component root also shows for me even if the component doesn't have anything in it. I can still load the component root folder. In your screenshot, it appears that you don't have any components at all in your workspace.


permanent link
Christian Morgan (317612) | answered Sep 10 '13, 9:56 a.m.
I believe you will need to either manually refresh the Pending Changes view so that it sees the file system you copied into the repository workspace's local sandbox.  There are two types of refresh operations, the default is to refresh changes made to the server side of the repository workspace and the second is for local changes.  You can click the small downward pointing arrow, just to the right of the refresh control on the pending changes view tab/title bar.

Default: Refresh remote changes
Optional: Refresh sandbox and remote changes

You can flip the default and optional with a preferences change, see below.
Window -- Preferences -- Team -- Jazz Source Control -- Changes -- Refreshing in pending changes view

In the long run having eclipse create a project for the file system shouldn't be an issue.  When bringing new file systems under version control (for eclipse/java based source or even non-java source), I first load my repo workspace and have the eclipse project created for the root of the component.  This let's me work within the RTC Java perspective and the package explorer.  I'll even ignore the ".project" file RTC creates for the eclipse project so that RTC/Pending Changes view will not try to version those files.  If you absolutely need to work external to RTC, some other IDE or directly from a file system explorer, then just make sure to refresh the pending changes view from the optional refresh above.

Comments
G H commented Sep 10 '13, 10:27 a.m.

Thanks for the reply.

I still don't think it has worked. I have clicked the down arrow in Pending Changes and clicked Refresh - and there is no indication that anything has happened. I still have no files in the Repository Files view and no pending changes or anything else. The only information in Pending Changes is a line of text thus:
My Repository Workspace <-> Integration Stream

I've tried this with both Changes options set to Refresh remote or refresh sandbox and remote - nothing.

PS. I don't have anything configured in Sandboxes, it won't let me add a folder (says 'this is not a Jazz source control sandbox')

So at this stage I don't even know if my files are in RTC or not...
 


permanent link
Christian Morgan (317612) | answered Sep 10 '13, 11:40 a.m.
Going back to your orig post, you say that the comp is listed under the Source Control--Components folder but not your repo wksp.  Try this, right click--open your repository workspace into the properties editor, (select the repo wksp and choose open), from the properties page in the middle there is a section "Components" --click--Add... and then search/select and add the component you need to that repo wksp configuration.  Save the changes to the repo wksp and then reload it.

Hopefully that will sort out the issue where the comp is not listed in the load dialog above.

Comments
G H commented Sep 10 '13, 12:25 p.m.

OK, now we are getting somewhere. I did as you suggested and got a component loaded under the repo wksp. I will keep testing. 


G H commented Sep 11 '13, 3:59 a.m.

Hmm, the component is now added to the repo wksp but it doesn't seem to have any files in it. Show Repository Files returns nothing.

Also, if I make a change to my file structure outside Eclipse and then refresh remote/sandbox, nothing happens.

I was hoping to get a bit further with this today but, at this rate, I may have to recommend alternatives to my team. 


Christian Morgan commented Sep 11 '13, 9:13 a.m. | edited Sep 11 '13, 9:25 a.m.

Without seeing exactly what you're up against, it's tough to pin point what is happening or not happening.....

Just a couple questions that may shed some light for me:
- After you loaded the repo workspace, you can now use a file system browser or other tool to browse to the local sandbox and within the component root folder, you have added new files & folders?
- Once you have confirmed that there are files and folders in the sandbox for the repo workspace, and after refreshing the sandbox and remote changes, do those newly added files/folders show up in the Pending Changes view?
- If they do show in pending changes, then they will be in the unresolved folder located underneath the tetris block looking component icon.  You now should be able to perform a check-in and then the deliver operation to get the files and folders pushed up from the sandbox to the server-side repo wksp (the check-in operation) and then pushed to the stream associated with the repo wksp (the deliver operation).
- Until you perform the check-in operation, the show repository files command will not return anything, because the files and folders are in the local sandbox but not in the repository workspace on the server yet.

RTC has 3 distinct layers of isolation which is a bit different from other scm tools.  The bottom layer is the sandbox (the local workspace on the users workstation/hard disk associated with the repository workspace), then the linked server-side repository workspace that catalogs all checked in versions (but is still isolated from the stream/branch), finally the last and highest layer is the stream where all team members deliver checked in change sets from their own private repository workspaces. 

If you already knew the general scm concepts above, I apologize for getting into it here.  I often have to get the distinction of the 3 layers across to teams that are more familiar with the traditional scm paradigm of simply checking out and checking in, having only the branch and their local workspace to contend with.

I hope this helps you in some ways.  It would be a shame to see you go another direction for a solution.  RTC is a really great solution with a lot of capability and features.


G H commented Sep 12 '13, 5:11 a.m. | edited Sep 12 '13, 5:12 a.m.

Everything was showing empty. In the end, I managed to get the project into RTC by first creating a general project within Eclipse, setting the project location to the folders I wanted to control and then sharing it with Jazz. Up to that point I had all sorts of issues with conflicting sandboxes, component errors and the like. I'm going to struggle on for a bit longer.

btw, I don't think there's any shame in looking for other solutions if your first experience of a tool is one of frustration due to lack of intuitive workflow or user-friendliness. Capability and features are not virtues; they're expected.
What I do appreciate is your willingness to help :)


permanent link
Christian Morgan (317612) | answered Sep 12 '13, 9:21 a.m.
Yes, RTC can be overwhelming and some aspects are not as intuitive I agree.  Don't misunderstand I wasn't implying that you should be ashamed, just that it is a shame to have you go a different direction.  We certainly would rather have more people join the community than explore other solutions, but you need to find a solution that is the right fit for you and your team.

Not to imply that you have done anything incorrectly, but unless there is a technical issue with the tool (client or server side), I bet we could have gotten you through the issue if we could have put a screen sharing session together.  I have been deploying to and supporting global teams with this solution for years and have never run into a situation where we couldn't get a file system imported and shared in the scm repository, sometimes it is just easier to talk and walk through it in a more direct way I suppose.

Wish I could have been of more help.

Good luck!

Your answer


Register or to post your answer.