It's all about the answers!

Ask a question

Can custom RPE reports be launched from the RRC web interface?


Joe Gariano (883137) | asked Sep 04 '13, 12:56 p.m.
retagged Sep 09 '13, 10:51 a.m. by Ralph Earle (25739)
At the bottom of the following article, it describes how to launch custom RPE reports from the RQM web interface: https://jazz.net/library/article/1137

Does a similar feature exist for RRC?  Inside the RRC web interface, I can see an option to generate a report (which gives me a list of out-of-the-box report), but it's not clear to me how I could upload and use a custom RPE report.

Note that I'm using RRC version 4.0.2 and RPE version 1.2.

Accepted answer


permanent link
Benjamin Silverman (4.1k610) | answered Sep 04 '13, 1:07 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Yes, you can deploy custom RPE reports in to RRC using this InfoCenter topic, specifically the section titled "Manually importing custom document-style report templates for requirements management".  Hope it helps,
Joe Gariano selected this answer as the correct answer

Comments
Joe Gariano commented Sep 04 '13, 2:27 p.m.

Thanks.  I'll look into this and see if I can get it to work.  I may post back in the future if I get stuck on something.


Joe Gariano commented Sep 05 '13, 8:35 p.m.

Benjamin,

So I gave it another try using RQM.  (I don't have access to the server that runs RRC, and it appears that I'll need to make some changes in on the server to get this working for RRC.  So before hunting down the IT people that do have that access, I figured I'd try to get it working in RQM first.)

First, I created a very simple .dta that just prints out "hello world".  I have a simple t.dsx that kicks that off.  The .dsx file tells it to generate a Word document.  Both are stored on my desktop.

Following the instructions at the link you provided, I create a report, and I upload the .dta to the contents section and the .dsx added to the files section.  I then create the report that uses that report resource.

However, when the report opens, I get the following error message at the top of the window:
"Could not load template C:\Windows\TEMP\reports_GTI-M51vEeKSvZIMpS1htA_XeHvTxaLEeOb4rvym5qF1g/template.dta. Error is: "

I've tried it a few different times with new reports to make sure I didn't mess anything up, but I always get that error.

Any ideas?


Alanna Zito commented Sep 06 '13, 10:18 a.m.
JAZZ DEVELOPER

Hi Joe,

RPE 1.2 reports are not compatible with CLM 4.0.2   You can still use RPE 1.2 to create your templates, but you must save them as "Version 1" in order to use them on the server.

Version 2 templates are supported as of CLM 4.0.3.

Your answer


Register or to post your answer.