It's all about the answers!

Ask a question

Getting IllegalArgumentException after loading the project from RTC

Prem Soman (1112) | asked Aug 08 '13, 5:16 p.m.
edited Aug 08 '13, 5:18 p.m.


  I am using the below components in our project:

  1.      Eclipse Helios version downloaded from

  2.      RTC plugins version - Downloaded the zip file "" and installed as per the instructions given in below page.

  3.      Kony - a third party application to develop mobile application. Its plugins were added into “dropins” folder of Eclipse.

  Below are the steps that I followed which resulted in the exception/error given below:

1.      From within the eclipse, connected to RTC stream, created a "repository workspace" and "loaded" a project.

This project is of type "Kony", a third party application. The ".project" file within this project has the below nature defined and it is the only nature, based on which the Kony plugins recognize this as their proprietary application and loads in their corresponding windows.




  2.      Once loaded, I switched to Kony's "application" window (it’s basically a perspective, similar to java, java ee etc.) and that’s when the below error is shown in the "console". This error causes the "build" (which is just an ant script) to fail or even refresh the project.

  Based on what I searched so far, same error was reported for eclipse 3.7 with maven m2e plugins and maven project maintained in RTC. The solutions mentioned cannot be applied as my project type is different.

Any suggestions will be helpful.

  java.lang.IllegalArgumentException: URI scheme is not "file"
 at<init>(Unknown Source)
 at com.pat.tool.keditor.utils.KUtils.buildServiceListByCat(
 at com.pat.tool.keditor.navigation.model.ServicesResourceRoot.refreshChildren(
 at com.pat.tool.keditor.views.NavigationViewUtils.refreshServicesModel(
 at com.pat.tool.keditor.views.NavigationViewUtils.refreshNonFormModules(
 at com.pat.tool.keditor.views.NavigationViewUtils.updateProjectModel(
 at com.pat.tool.keditor.views.NavigationViewUtils.access$000(
 at com.pat.tool.keditor.views.NavigationViewUtils$
 at com.pat.tool.keditor.views.NavigationView$


One answer

permanent link
Krzysztof Kaźmierczyk (7.4k35799) | answered Aug 09 '13, 3:35 a.m.
Hi Prem,
The error message goes from Kony application. If the project is third party application, you need contact the support of that appliction. They should know how to correct their application.

Best regards,
Krzysztof Kazmierczyk

Prem Soman commented Aug 09 '13, 11:38 a.m. | edited Aug 09 '13, 11:40 a.m.

Hi Krzysztof,

Thanks for your answer. We did reach out to the Kony team but since their product was not certified to work with RTC, they could not analyze any further. Since our organization uses RTC we were trying to integrate both.

During our analysis, we found that Eclipse works with Kony plugins added to it without any issues. This error occurs only when we add the RTC plugins & load the code into the same eclipse instance. Hence the Kony product support team pointed that the issue could be with RTC plugins.

On some forums, I also found many such issues with same error (java.lang.IllegalArgumentException: URI scheme is not "file") with m2e plugin where the project was of type Maven maintained in RTC. Since that error was resolved with some modified RTC plugins, I thought this could be some issue related to RTC plugins that we use

I thought, ideally, any source code managment product should work with any type of project irrespective of the nature. Please let me know your views.

Your answer

Register or to post your answer.