It's all about the answers!

Ask a question

CRRTC3521W: Warning: The build engine is either not in the repository, or it cannot be accessed by the following user


Andy Jewell (24225771) | asked Jul 31 '13, 11:51 a.m.
This is a spin-off of another question I've posted regarding an "API Access Denied" error while using Build Forge and the RTC source adapter to start an RTC build.  I'm trying to break that problem down and simply trying to start the JBE using the following command line:

/opt/jazz/buildsystem/buildengine/eclipse/jbe.sh -repository https://ourrepo:9443/ccm/ -userId myuser pass mypass  -verbose -engineId 'jbeengine'

I've done this successfully on another project (which is also having the error referenced in my other question), but for this project I can't even get it to find the build engine, I get this error:

2013-07-31 08:29:46 [Jazz build engine] Running build loop...
2013-07-31 08:29:47 [Jazz build engine] Not using a proxy to reach https://ourrepo:9443/ccm/
2013-07-31 08:29:50 [Jazz build engine] CRRTC3521W: Warning: The build engine is either not in the repository, or it cannot be accessed by the following user: "myuser". The ID of the build engine is "jbeengine". For more details, open the help system and search for CRRTC3521W.
2013-07-31 08:29:50 [Jazz build engine] No requests found.

I've verified that:

1) the 'myuser' RTC user is in the project
2) the user has all the Build rights I can find (also tried this with an Admin account that has virtually EVERY permission and I get the same result)
3) the workspace attached to build definition is owned by the 'myuser' account

As I mentioned above, we have another repository where this works against but I'm not sure what could be different across repositories to get this error.

Any idea how I can troubleshoot this further??


- Andy

Accepted answer


permanent link
Scott Cowan (966310) | answered Jul 31 '13, 3:00 p.m.
JAZZ DEVELOPER
Hi Andy,

I just tested this out and I think the only problem is the unnecessary single quotes around the build engine ID right at the end of your command line.  Try this out.
/opt/jazz/buildsystem/buildengine/eclipse/jbe.sh -repository https://ourrepo:9443/ccm/ -userId myuser pass mypass  -verbose -engineId jbeengine
Scott
Andy Jewell selected this answer as the correct answer

Comments
Andy Jewell commented Jul 31 '13, 3:07 p.m.

HI, Scott - thanks for suggesting this, I just tried and apparently in my case it didn't make a difference.  I tried no quotes, single quotes, and double quotes and it gives me the same message in each case.


1
Scott Cowan commented Jul 31 '13, 3:49 p.m. | edited Jul 31 '13, 3:51 p.m.
JAZZ DEVELOPER

Hmmm... That's funny, I reproduced the exact same CRRTC3521W problem by taking a working JBE command line and adding single quotes around the -engineId value.

I also noticed your original -pass parameter is missing the dash.  I copy/pasted the same problem in my answer above.  However, when the only mistake I make in the command line is leaving out the dash in -pass I get this error,

CRRTC3507E: Invalid arguments used for authentication.

Is that the problem you're getting now?  If so, add the dash and try again.

If not, then try verifying your credentials in the web UI.  Copy/paste the -repository value from the the command line into your browser and append "web" to the end.  Then copy/paste the -userId value and -pass value into the login page and verify you can log in.  Select the project area you're working in.  Select "Build Engines" from the Builds menu and verify you can see the build engine with the -engineId value you're using.

If you can't see the build engine then you have a permission problem to work out.

Scott


Andy Jewell commented Aug 01 '13, 11:11 a.m.

Yeah, I hear what you're saying.  I'm not sure if the original command I had above was a paste error or what but since you brought up the single quote issue, I've put the command in a hundred different ways (including different option orders) and still no change in result.


However, this morning after reading your message I tried changing user accounts and the build was successful!  I went back the account I had started with in the first place.  That first account has virtually every permission but was getting the same error (at least I thought it was!).  So anyhow, I think in the end you were right, permission problem.  And the problem was the user was not in the project.  The user had the role and the role had the permissions and the workspace was owned by the user but. . . not in the project.  So silly, my bad!  Thanks for your help!


Scott Cowan commented Aug 01 '13, 1:37 p.m.
JAZZ DEVELOPER

Awesome! Glad you're unblocked!

Scott :-)

Your answer


Register or to post your answer.