It's all about the answers!

Ask a question

Why can't I create a repository workspace or set a sandbox with shell for rtc 4.0.0.1?


Andrew Trobec (49712139139) | asked May 06 '13, 2:27 a.m.
Hello,

I am working with the Shell client for RTC 4.0.0.1 and am having difficulty.  I have created a repository connection to my server and connected to the project area.  When trying to create a repository workspace that flows with a stream, I get the error "Error retrieving data. Check the log for details".  When I check the log I don't see anything.

When trying to set a sandbox I don't seem to get any errors.  A new folder, .jazz5, gets created in the directory that I converted into my sandbox.  When I try to see the sandbox to the control panel it doesn't list under the "Sandboxes" section.  The log shows:

FilesystemUILibrary: com.ibm.team.foundation.core.exception.CoreException: Error setting sandbox ---> com.ibm.team.foundation.service.RestTransportException: Error executing http://localhost:50065/service/com.ibm.team.filesystem.client.rest.IFilesystemRestClient/SandboxListeningEnablement ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond <xx.xx.xx.xx>:50065

I have tried a number of times to create different sandboxes and every time the error is the same except for the port that changes.  Do I need a repository workspace before I can create a sandbox?

What could the problem be?

Regards,

Andrew

Comments
Tim Mok commented May 06 '13, 9:42 a.m.
JAZZ DEVELOPER

What's the server version and the URI you use to connect to it?


Andrew Trobec commented May 07 '13, 2:18 a.m. | edited May 07 '13, 2:22 a.m.

Hi Tim,

Thanks for the reply.
The server is 4.0.0.1 and the shell client is for that version.  I downloaded it from this All Downloads page.
The URI that I have used to connect is that same that I'd use for the RTC client: https://<server>/ccm/
After starting Windows 7, trace logs show no error messages.  I connect to the project area and still no error messages.  When I try to create a new repository workspace and flow it with the stream, the following error appears after I expand the repository connection (first it freezes for a minute with "Pending... (50%)": Error retrieving data. Check log for details.
The logs contain no errors.  The location of the logs is C:\Users\<user>\AppData\Roaming\IBM\Rational\Team Concert Shell.
When trying to create a new sandbox, the error listed in my question appears.  This morning it is on port 65259.
Regards,
Andrew


Balamurugan Selvarasu commented Apr 05 '15, 3:45 a.m. | edited Apr 05 '15, 11:22 a.m.

Hello Andrew,


I am facing issue in my system. So I have removed the localhost related entries and trying to create a new repository workspace but still I am facing the same issue.

Did anyone have a resolution for this issue.

Regards,
BalaMurugan S

Accepted answer


permanent link
Andrew Trobec (49712139139) | answered May 07 '13, 6:38 a.m.
Hello again Tim,

Before wasting any more of your time, I'd like to inform you that I found the problem.  My HOSTS file under C:\Windows\System32\drivers\etc forwarding localhost to another address for some other activities.  I discovered that it conflicted with the RTC Shell.  By removing that translation it resolved my issue!

Regards,

Andrew
Millard Ellingsworth selected this answer as the correct answer

Your answer


Register or to post your answer.