It's all about the answers!

Ask a question

RTC timeouts very frequently.


SMitha kumari (245254) | asked Apr 15 '13, 2:33 a.m.

Hi,

I am using RTC 4.0, It suddenly timesout when actively using.. What could be the issue?

Regards,
Smitha


Comments
Ralph Schoon commented Apr 15 '13, 4:47 a.m. | edited Apr 15 '13, 4:48 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Hi, can you provide better information on the issues you have? What Times out? What UI are you using. How does the timout show? What is your environment, network connection to the server, where is it located and how is it set up?


SMitha kumari commented Apr 15 '13, 5:07 a.m. | edited Apr 15 '13, 5:08 a.m.

Hi Ralph,

I am using IE or Mozilla.

Scenario is: Login in to RTC, work for couple of minutes & keep it ideal for couple of minutes.. Once you are back it allows to continue the work. But suddenly it enforces me to relogin & at time restarting the browser and relogin is the only solution.

Regards,
Smitha


Ralph Schoon commented Apr 15 '13, 5:10 a.m. | edited Apr 15 '13, 5:11 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Do you have access to the log files of JTS and CCM?
I have never seen such a behavior. The session timeout is typically set to 6 hours. I can only suspect an issue with the network - some infrastructure dropping sessions or an issue with the browser. What sometimes helps with browser issues is clearing the history and cache.

3 answers



permanent link
Indradri Basu (1.8k1514) | answered Apr 15 '13, 7:11 a.m.
I would agree with Ralph's direction. In WAS Admin Console, you can find it in Servers > Server Types > Application servers > server1 > Session management. By default the session timeout is 30 minutes in WAS (as I noticed in WAS 8.0.0.4) and all the applications inherit this property. But you can choose to override the session timeout for the application(s) (like JTS or CCM) by going to the respective Application's session management page See the screen shot below.

Check the highlighted checkbox and increase the timeout value. You may want to restart the application only from Enterprise applications page for the changes to take effect.

WAS session timeout

I would be very interested to know the feedback.


permanent link
SMitha kumari (245254) | answered Apr 15 '13, 5:50 a.m.

Thanks Ralph.. were can I see session time out set to 6 hours in JTS and WAS setup.


permanent link
Ralph Schoon (61.1k33643) | answered Apr 15 '13, 6:17 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
The information can be found in the Web.xml file in the war file. I don't presently know where WAS extracts it to.


Comments
Ralph Schoon commented Apr 15 '13, 6:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I also don't think you have an issue with that timeout. You might have an issue with your infrastructure or WAS. I would consider looking into the Log files for WAS, CCM, JTS.

Your answer


Register or to post your answer.