It's all about the answers!

Ask a question

Repainting problems with RTC 1.0.1


Scott Chapman (3216347) | asked Nov 21 '08, 1:42 p.m.
I am seeing lots and lots of screen painting issues with V1.0.1 (using the included eclipse).

Some are just annoying, but others render the product pretty unusable.

Since they are really all over the place, it is likely to be some general problem rather than something isolated to one particular area. Is there someone on the team that I can show what I am seeing to figure out how to create defects for these issues?

6 answers



permanent link
Todd Lainhart (40611) | answered Nov 21 '08, 5:18 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
ScottChapman wrote:
I am seeing lots and lots of screen painting issues with V1.0.1 (using
the included eclipse).

Some are just annoying, but others render the product pretty
unusable.

Since they are really all over the place, it is likely to be some
general problem rather than something isolated to one particular
area. Is there someone on the team that I can show what I am seeing
to figure out how to create defects for these issues?


Scott - I've never seen nor heard of any redraw issues using RTC, and I've been
using it for at least a couple of years (on Windows). You can shoot me mail if
you like.

--
Todd Lainhart
Jazz Repository/Foundation Team

permanent link
David Olsen (5237) | answered Nov 22 '08, 9:58 p.m.
JAZZ DEVELOPER
Todd Lainhart wrote:
ScottChapman wrote:
I am seeing lots and lots of screen painting issues with V1.0.1 (using
the included eclipse).

Some are just annoying, but others render the product pretty
unusable.

Scott - I've never seen nor heard of any redraw issues using RTC, and
I've been using it for at least a couple of years (on Windows). You can
shoot me mail if you like.

I'm seeing it too. It's a regression in 1.0.1. I never saw this in 1.0
or any of the pre-releases.

For me, the problem is work items open in the editor. If I come back to
RTC from some other application, the work item displays incorrectly.
Usually the description and comment fields are too narrow. The box
around those fields is fine, but the text inside them is wrapped much
more narrow than it needs to be. Sometimes the box to enter a new
comment looks fine, but has problems scrolling vertically.

I wouldn't say that RTC becomes almost unusable. But it is very
annoying. The workaround is easy enough: Press Ctrl-M twice to make the
editor window full screen and back. The work item window repaints
correctly when I do that. But that's the only way I have found that
consistently fixes the problem.

permanent link
Work Item & UI Commons Team (1.3k1) | answered Nov 24 '08, 5:29 a.m.
This could be due to https://bugs.eclipse.org/bugs/show_bug.cgi?id=148509. Is there any chance you could try RTC with Eclipse 3.4.1 as platform and see if it resolves this issue?

permanent link
Scott Chapman (3216347) | answered Dec 01 '08, 1:58 p.m.
That doesn't come up as a valid bug.

And yes it does become unusable for me; Sometimes text boxes become black (but may also just be a re-sizing problem).

permanent link
Marcel Bihr, Jazz Work Item team (1.4k) | answered Dec 02 '08, 3:31 a.m.
JAZZ DEVELOPER
The correct URL is: https://bugs.eclipse.org/bugs/show_bug.cgi?id=148509 .

Regards

Marcel
Jazz Work Item team

permanent link
Jakub Jurkiewicz (59632) | answered Dec 02 '08, 4:21 a.m.
This could be due to https://bugs.eclipse.org/bugs/show_bug.cgi?id=148509. Is there any chance you could try RTC with Eclipse 3.4.1 as platform and see if it resolves this issue?


While installing RTC via Install Manager you have the possibility to install RTC plugins into Eclipse instance, so you can try to use Eclipse 3.4.1 as the platform for RTC.

Your answer


Register or to post your answer.