It's all about the answers!

Ask a question

What is the trusted client URI of my RRDI server so I can disable the oauth warnin pop-up?


Guido Schneider (3.4k1381108) | asked Feb 09 '13, 5:22 a.m.
retagged Feb 11 '13, 3:52 p.m. by Ralph Earle (25739)
If I run a RRDI report out of Jazz or perform an additional reporting task, I always get a popup asking me if the server "com.ibm.rational.reporting" is allowed to collaborate with my jazz server. This is boring.

In the online help, "Administering RRDI", chapter 1.1 "Setting up collaboration with the Jazz team Server" is written how I can specify my reporting server as a trusted client, so this message is not shown anymore.

There are two issues here:
a) the documentation is outdated. The advanced properties mentioned in the docu have other names. 
b) it is not working. I assume I do not know the URI of my reporting server.

I configured following parameter:

Section: ".ibm.team.repository.service.internal.oauth.TrustedCallbackService"
Property: "Trusted URIs for client authorization and redirection"
Value: "https://clmserver01.div.mycompany.com/"

But I still get following pop-up:
Authorization Popup

Interesting thing here is: Jazz thinks the name of my server is "com.ibm.rational.reporting".

Question: qhat is wrong here? What is the URI I have to provide in the advanced properties?

My configuration: 
I have setup RRDI on my CLM server. I have a ALL-IN-1 Configuration. That means, JTS, CCM, RM, QM and RRDI are all on the same machine, but each in a separate WAS profile.
As frontend WEBserver I have IHS and the IHS-Plugin for WAS configured. 

My URL's are as follow:
https:/clmserver01.div.mycompany.com/jts
https:/clmserver01.div.mycompany.com/ccm
https:/clmserver01.div.mycompany.com/qm
https:/clmserver01.div.mycompany.com/reporting

I have configured cognos according the documentation (gateway, dispatcher, SSL etc.)

RRDI is working well. I can deploy and  run reports in CCM or QM or directly execute reports in Cognos Command.

Accepted answer


permanent link
Michael Walker (99214198157) | answered Feb 09 '13, 3:11 p.m.
Guido,

I had this same issue last week and had the same popup text except for the server and id name.  I got it to work by following the instructions in the CLM 4.0.1 help in the path shown below.

Basically I modified the jazzns_config.xml file and set the  jazz-namespace encrypted property to false . I then updated the oauth key and secret to match what's listed under com.ibm.rational.reporting in the JTS admin.  After saving the modified xml file I then went to the following URL, which automatically reloaded and encrypted the jazzns_config.xml file.  The popup then went away.

http:// [report_server_host] : [port] /reporting/servlet/dispatch?CAMNamespace=Jazz&reloadJNSConfig=true

Here's the path to the same instructions in the Help:

Administering > Administering reporting > Administering Rational Reporting for Development Intelligence > Accounts and authentication

Modifying the authentication properties manually


Guido Schneider selected this answer as the correct answer

Comments
Michael Walker commented Feb 09 '13, 3:11 p.m.

There's also a section on doing it through the setup utility, but it was pretty quick to do manually.


Guido Schneider commented Feb 11 '13, 8:31 a.m. | edited Feb 11 '13, 8:48 a.m.

Hello Michael,

I deleted the oauth consumer key in JTS, the value in advanced settings and did it again.
Surprise: now it works! I'm not absolutly sure what has changed. Maybe a typo I have not seen.
Thanks for your support
Guido

One other answer



permanent link
Ali Manji (59147) | answered Feb 11 '13, 8:39 a.m.
JAZZ DEVELOPER
Hi Guido - Have a look at the section titled: "Identifying the report server as a trusted client on the Jazz Team Server" in this Info Center topic:

http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/index.jsp?topic=%2Fcom.ibm.rational.rrdi.admin.doc%2Ftopics%2Ft_configure_custom_reporting_clm_setup.html

Regards,
Ali

Comments
Guido Schneider commented Feb 11 '13, 10:53 a.m.

Thanks Ali,

it works know. It looksl like I had somewhere a typo. I cleande all out and did it again.

In this version of the document, the section and property of the advanced settings is correctly referenced. It seems it has changed between 4.0 and 4.0.1

Your answer


Register or to post your answer.