It's all about the answers!

Ask a question

Inconsistent behavior downloading an attachment from work item

Victor Campbell (3502618) | asked Feb 04 '13, 1:14 p.m.
We are using RTC 4.0.  A user attaches a document to a work item using the web interface.  Clicking on the attachment ID number in the attachment section of a work item returns "webpage not found".   Clicking on the "attachment xxxx" in the discussion section allows the document to be downloaded.  Am I using this incorrectly, or am I encountering a bug?

Millard Ellingsworth commented Feb 04 '13, 6:52 p.m.

If you use the name rather than the number in the attachment view, do you get the error or does it open?

I tried this in 3.0.1.x and 4.0.x and it worked fine for me using either path. However, I noticed that the link in the Comments section and the link in the Attachments sections are different -- that can explain the difference in behavior. Why one works and the other doesn't will take more investigation.

Attachments section:

Comments section:

Work Item 72951 indicates that the first version may be the preferred one.

Can you use Copy Link Address or similar browser functionality to paste in the 2 different URLs you see? There may be something we can work on with that.

Victor Campbell commented Feb 05 '13, 9:53 a.m. | edited Feb 05 '13, 9:58 a.m.

From history or discussion (this one works):


From the attachment page (same link on either attachment number or file name, returns HTTP 400 Bad Request):


Your link is different than mine.  My link also includes the drive letter along with the file name.  When I remove the "C%3A%5C" from the link, leaving only the filename, the link works.

Victor Campbell commented Feb 05 '13, 10:16 a.m. | edited Feb 05 '13, 11:10 a.m.

I can add another clue, I'm using IE 9 with Windows 7, and attaching a document will also include the drive letter along with the filename.  When using Firefox, the drive letter is not included in the filename.  So this looks like the problem is created when attaching the document, preventing it to be downloaded using the link. 

Millard Ellingsworth commented Feb 05 '13, 1:40 p.m.

It looks like whoever installed your RTC did not choose to use the new context roots which is why yours begin with "jazz" (old-school) and mine with "ccm".

Victor Campbell commented Feb 05 '13, 1:51 p.m. | edited Feb 05 '13, 2:25 p.m.

Wasn't this caused by an upgrade from RTC 2.0 to 4.0 (with an intermediate stop at 3.0)?  A quote from the upgrade document:

"The Change and Configuration Management (CCM) application must be deployed at the same context root that was used in your Rational Team Concert™ v2.x installation. By default, this is /jazz. The Rational Team Concert v3.0 installation can handle changing the CCM context root from /ccm to /jazz."

Here's a table that shows it also:

The upgrade process, as complicated as it was, didn't lend me to believe I could "choose" my context root.

Anyway, does that affect the way IE 9 with Windows 7 attaches documents? 

Millard Ellingsworth commented Feb 05 '13, 1:57 p.m.

No, not related (afaik). Just commenting on why our URLs are different. 

showing 5 of 6 show 1 more comments

Accepted answer

permanent link
Millard Ellingsworth (2.5k12431) | answered Feb 05 '13, 1:47 p.m.
This seems to be one of those difficult to reproduce issues. It was reported internally recently but closed since it wasn't reproducible by the development team. I have reopened and referenced this thread from the work item.

Please take a moment to review the item and add any information you may have to help reproduce and resolve.

Victor Campbell selected this answer as the correct answer

Your answer

Register or to post your answer.