Version Compatibility Matrix for RRDI, CLM, and Rational Insight

Last updated: September 6, 2013 to include the information on CLM 4.0.4, and RRDI 2.0.4
Build basis: Rational Reporting for Development Intelligence 2.0.4
Please be aware:The content of this article has been migrated to the Deployment wiki: Version Compatibility Matrix for RRDI, CLM, and Rational Insight topic page. The content will be maintained and updated in the wiki going forward. Therefore, this version of the article might not contain the most up to date information.

All deployment guidance and best practice will be published in the Deployment wiki rather than as Jazz.net articles going forward.

Rational Reporting for Development Intelligence (RRDI) is Rational’s strategic reporting solution for the CLM products: RTC, RQM, and RRC. It provides advanced reporting capabilities by integrating a fully functional Cognos reporting solution into a CLM installation.

Rational Insight builds on RRDI by adding additional capabilities:

  • Ability to aggregate data from multiple JTS into a single data warehouse for integrated reporting
  • Data acquisition from more Rational products
  • Many Out Of The Box reports providing directly useful information. They can also be customized to meet customer specific requirements.
  • Ability to customize the Data Warehouse, ETL, and reporting data model
  • Scorecard creation tools
  • Support for namespaces other then “Jazz”
  • Provdes additional Cognos functionality:
         Business Insight
         Business Insight Advanced
         Event Studio
Both RRDI and Insight can integrate with CLM for data acquisition, use of a common data warehouse, user authentication, and the ability to execute and view reports through the CLM product’s UI. This brings up the question of what versions of these products are compatable and how to perform upgrades.

The upgrade procedure for RRDI 2.0.4 can be found in the CLM 4.0.4 Info Center. The general process is to upgrade CLM first, then upgrade RRDI. See Upgrading RRDI for the detailed procedure.

The upgrade procedure for Rational Insight 1.1.1.2 can be found in the updated Insight 1.1.1 Info Center. See Upgrading Rational Insight for the detailed procedure.

RRDI Upgrade compatibility

For RRDI, the following rules govern upgrades and version compatibility with CLM
  • When upgrading, upgrade CLM first, then RRDI. The report packages for CLM (in the form of Cognos archives) should be loaded after RRDI upgrade.
  • RRDI and CLM upgrades do not have to be done atomically. Intermediate states are supported.
  • When upgrading from CLM 3.0.1.*, there are required minimum versions of the RQM and RRC applications. See the CLM documentation for details.
  • The table below shows the supported combinations
  • The table does not show upgrades to RRDI 2.0, as you should upgrade to 2.0.0.1 instead
  • Upgrading from RRDI 2.0.0.1 implies either from RRDI 2.0 or 2.0.0.1
RRDI Version       Supported CLM Versions
1.0.2.* JTS 3.0.1.* and RTC, RQM, RRC at 3.0.1.*
2.0, 2.0.0.1 JTS 4.0.0.* and RTC, RQM, RRC at 3.0.1.* or 4.0.0.*
2.0.1 JTS 4.0.1.*/4.0.2 and RTC, RQM, RRC at 3.0.1.*, 4.0.0.*, 4.0.1, or 4.0.2
2.0.3 JTS 4.0.3 and RTC, RQM, RRC at 3.0.1.*, 4.0.0.*, 4.0.1.*, 4.0.2, or 4.0.3
2.0.4 JTS 4.0.4 and RTC, RQM, RRC at 3.0.1.*, 4.0.0.*, 4.0.1.*, 4.0.2, 4.0.3, or 4.0.4

Upgrade paths exists for the following release combinations. CLM versions in the following table refer primarily to the JTS version where the actual CLM applications (RTC, RQM, RRC) can be that same version or a prior version supported by that JTS version.

From Release To Release
CLM 3.0.1.* / No RRDI             CLM 3.0.1.* with RRDI 2.0.0.1 or 2.0.1 or 2.0.4
CLM 3.0.1.* / No RRDICLM 4.0.0.* with RRDI 2.0.0.1 or 2.0.1 or 2.0.4
CLM 3.0.1.* / No RRDICLM 4.0.4 with RRDI 2.0.4
CLM 3.0.1.* / RRDI 1.0.2CLM 3.0.1.* with RRDI 2.0.0.1 or 2.0.1 or 2.0.4
CLM 3.0.1.* / RRDI 1.0.2CLM 4.0.0.* with RRDI 2.0.0.1 or 2.0.1 or 2.0.4
CLM 3.0.1.* / RRDI 1.0.2CLM 4.0.4 with RRDI 2.0.4
CLM 3.0.1.* / RRDI 2.0.0.1CLM 3.0.1.* with RRDI 2.0.1 or 2.0.4
CLM 3.0.1.* / RRDI 2.0.0.1CLM 4.0.0.* with RRDI 2.0.1 or 2.0.4
CLM 3.0.1.* / RRDI 2.0.0.1CLM 4.0.4 with RRDI 2.0.4
CLM 3.0.1.* / RRDI 2.0.1CLM 4.0.0.* with RRDI 2.0.1 or 2.0.4
CLM 3.0.1.* / RRDI 2.0.1CLM 4.0.4 with RRDI 2.0.1 or 2.0.4
CLM 3.0.1.* / RRDI 2.0.3CLM 4.0.0.* with RRDI 2.0.4
CLM 3.0.1.* / RRDI 2.0.3CLM 4.0.4 with RRDI 2.0.4
CLM 4.0.0.* / No RRDICLM 4.0.0.* with RRDI 2.0.0.1 or 2.0.1 or 2.0.4
CLM 4.0.0.* / No RRDICLM 4.0.4 with RRDI 2.0.4
CLM 4.0.0.* / RRDI 2.0.0.1CLM 4.0.0.* with RRDI 2.0.1 or 2.0.4
CLM 4.0.0.* / RRDI 2.0.0.1CLM 4.0.4 with RRDI 2.0.4
CLM 4.0.0.* / RRDI 2.0.1CLM 4.0.4 with RRDI 2.0.1 or 2.0.4
CLM 4.0.0.* / RRDI 2.0.3CLM 4.0.4 with RRDI 2.0.3 or 2.0.4
CLM 4.0.1.* / No RRDICLM 4.0.1.* with RRDI 2.0.1 or 2.0.4
CLM 4.0.1.* / No RRDICLM 4.0.4 with RRDI 2.0.4
CLM 4.0.1.* / RRDI 2.0.1CLM 4.0.4 with RRDI 2.0.4
CLM 4.0.1.* / RRDI 2.0.3CLM 4.0.4 with RRDI 2.0.4
CLM 4.0.2 / No RRDICLM 4.0.4 with RRDI 2.0.4
CLM 4.0.2 / RRDI 2.0.1CLM 4.0.4 with RRDI 2.0.4
CLM 4.0.2 / RRDI 2.0.3CLM 4.0.4 with RRDI 2.0.4
CLM 4.0.3 / No RRDICLM 4.0.4 with RRDI 2.0.4
CLM 4.0.3 / RRDI 2.0.3CLM 4.0.4 with RRDI 2.0.4
CLM 4.0.4 / No RRDICLM 4.0.4 with RRDI 2.0.4

Rational Insight Upgrade compatibility

The latest release of Rational Insight is 1.1.1.2. It is built on top of RRDI 2.0.3, so any upgrade to it will include upgrading to RRDI 2.0.3 as well. RRDI 2.0.4 is compatible with RRDI 2.0.3, so it can also be used as the base for Rational Insight 1.1.1.2.

The following rules govern Rational Insight upgrades:

  • Insight 1.1.1.2 requires JTS 4.0.3 / 4.0.4 and 4.0.3 / 4.0.4 Data Manager ETLs for the minimal configuration. You can have CLM 4.0.0.* or 4.0.1.* or 4.0.2 applications, though you must use the proper version of the ETLs. JTS 4.0.3 /4.0.4 and 4.0.3 / 4.0.4 Data Manager ETLs are also compatible with Insight 1.1.1.2.
  • CLM 4.0.3 and 4.0.4 requires Insight 1.1.1.2.
  • When upgrading both JTS and Insight, Insight MUST be upgraded first and both upgrades MUST be done atomically. Intermediate states are not supported. The CLM applications can be upgraded later, provided you use the correct ETLs.
  • When upgrading the JTS from 3.0.1.* to 4.0.0.* or above, CLM has minimum required versions of RQM and RRC. See the CLM upgrade documentation.
  • The table below shows supported release combinations.
If you are using Rational Insight with CLM, this table shows which Insight version works with each JTS version. Note that you must choose the proper Insight version for the JTS version. Unlike RRDI, an Insight version will need to work with a compatible JTS version (or at least one JTS with a compatible version in a multi-JTS deployment topology). Older CLM applications will work with Insight, provided the JTS version is compatible. To use older CLM applications, you must get the proper Cognos Data Manager ETL jobs. They are supplied with the JTS. The reason for this is that the ETL jobs must match the Data Warehouse schema created by the JTS, and use the proper REST web interface to access the CLM application.

Insight Version    Supported CLM Versions ETL Requirement
1.1 JTS 3.0.1.* and RTC, RQM, RRC at 3.0.1.*
1.1.1 JTS 4.0.0.* and RTC, RQM, RRC at 3.0.1.* Data Manager ETLs from JTS 4.0.0.* for the 3.0.1.* apps
1.1.1 JTS 4.0.0.* and RTC, RQM, RRC at 4.0 or later
1.1.1.1 JTS 4.0.1.*/4.0.2 and RTC, RQM, RRC at 3.0.1.* Data Manager ETLs from JTS 4.0.1.*/4.0.2 for the 3.0.1.* apps. See CLM documentation for required 3.0.1 fixpack levels
1.1.1.1 JTS 4.0.1.*/4.0.2 and RTC, RQM, RRC at 4.0.0.* Data Manager ETLs from JTS 4.0.1.*/4.0.2 for the 4.0.0.* apps
1.1.1.1 JTS 4.0.1.*/4.0.2 and RTC, RQM, RRC at 4.0.1.* Data Manager ETLs from JTS 4.0.1.*/4.0.2 for the 4.0.1.* apps
1.1.1.1 JTS 4.0.2 and RTC, RQM, RRC at 4.0.2
1.1.1.2 JTS 4.0.3/4.0.4 and RTC, RQM, RRC at 3.0.1.* Data Manager ETLs from JTS 4.0.3/4.0.4 for the 3.0.1.* apps. See CLM documentation for required 3.0.1 fixpack levels
1.1.1.2 JTS 4.0.3/4.0.4 and RTC, RQM, RRC at 4.0.0.* Data Manager ETLs from JTS 4.0.3/4.0.4 for the 4.0.0.* apps
1.1.1.2 JTS 4.0.3/4.0.4 and RTC, RQM, RRC at 4.0.1.* Data Manager ETLs from JTS 4.0.3/4.0.4 for the 4.0.1.* apps
1.1.1.2 JTS 4.0.3/4.0.4 and RTC, RQM, RRC at 4.0.2 Data Manager ETLs from JTS 4.0.3/4.0.4 for the 4.0.2 apps
1.1.1.2 JTS 4.0.3/4.0.4 and RTC, RQM, RRC at 4.0.3 Data Manager ETLs from JTS 4.0.3/4.0.4 for the 4.0.3 apps
1.1.1.2 JTS 4.0.3/4.0.4 and RTC, RQM, RRC at 4.0.4

Upgrade paths exists for the following release combinations. CLM versions in the following table refer primarily to the JTS version where the actual CLM applications (RTC, RQM, RRC) can be that same version or a prior version supported by that JTS version. However, use of a prior version application will also require usage of the appropriate Data Manager ETL.

From Release To Release
No CLM / Insight 1.1 or prior             No CLM with Insight 1.1.1.2
No CLM / Insight 1.1 or priorCLM 4.0.0.* with Insight 1.1.1
No CLM / Insight 1.1 or priorCLM 4.0.4 with Insight 1.1.1.2
No CLM / Insight 1.1.1No CLM with Insight 1.1.1.2
No CLM / Insight 1.1.1CLM 4.0.0.* with Insight 1.1.1
No CLM / Insight 1.1.1CLM 4.0.4 with Insight 1.1.1.2
CLM 3.0.1.* / No ReportingCLM 3.0.1.* with Insight 1.1.1   
CLM 3.0.1.* / No ReportingCLM 4.0.0.* with Insight 1.1.1
CLM 3.0.1.* / No ReportingCLM 4.0.4 with Insight 1.1.1.2
CLM 3.0.1.* / Insight 1.1CLM 4.0.0.* with Insight 1.1.1
CLM 3.0.1.* / Insight 1.1CLM 4.0.4 with Insight 1.1.1.2
CLM 3.0.1.* / RRDI 1.0.2CLM 4.0.0.* with Insight 1.1.1
CLM 3.0.1.* / RRDI 1.0.2CLM 4.0.4 with Insight 1.1.1.2
CLM 3.0.1.* / RRDI 2.0.0.1CLM 4.0.0.* with Insight 1.1.1
CLM 3.0.1.* / RRDI 2.0.0.1CLM 4.0.4 with Insight 1.1.1.2
CLM 3.0.1.* / RRDI 2.0.1CLM 4.0.4 with Insight 1.1.1.2
CLM 3.0.1.* / RRDI 2.0.3CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.0.* / No ReportingCLM 4.0.0.* with Insight 1.1.1
CLM 4.0.0.* / No ReportingCLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.0.* / Insight 1.1.1CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.0.* / RRDI 2.0.0.1CLM 4.0.0.* with Insight 1.1.1
CLM 4.0.0.* / RRDI 2.0.0.1CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.0.* / RRDI 2.0.1CLM 4.0.0.* with Insight 1.1.1
CLM 4.0.0.* / RRDI 2.0.1CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.0.* / RRDI 2.0.3CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.1.* / No ReportingCLM 4.0.2 Insight 1.1.1.1
CLM 4.0.1.* / No ReportingCLM 4.0.4 Insight 1.1.1.2
CLM 4.0.1.* / Insight 1.1.1.1CLM 4.0.2 with Insight 1.1.1.1
CLM 4.0.1.* / Insight 1.1.1.1CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.1.* / RRDI 2.0.1CLM 4.0.2 with Insight 1.1.1.1
CLM 4.0.1.* / RRDI 2.0.1CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.1.* / RRDI 2.0.3CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.2 / No ReportingCLM 4.0.2 Insight 1.1.1.1
CLM 4.0.2 / No ReportingCLM 4.0.4 Insight 1.1.1.2
CLM 4.0.2 / Insight 1.1.1.1CLM 4.0.4 Insight 1.1.1.2
CLM 4.0.2 / RRDI 2.0.1CLM 4.0.2 with Insight 1.1.1.1
CLM 4.0.2 / RRDI 2.0.1CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.2 / RRDI 2.0.3CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.3 / No ReportingCLM 4.0.4 Insight 1.1.1.2
CLM 4.0.3 / Insight 1.1.1.2CLM 4.0.4 with Insight 1.1.1.2
CLM 4.0.3 / RRDI 2.0.3CLM 4.0.4 with Insight 1.1.1.2

Multiple Jazz Team Server Deployment Consideration: Insight also supports an integration with multiple Jazz Team Servers at different versions (eg one JTS v4.0.3 and one JTS at v3.0.1.1). In order to support this, the Insight version must match the highest level JTS in your multiple-JTS environment. For example, if you have two CLM environments, one with a JTS v4.0.3 and the other with a JTS v3.0.1.1. Insight must support the highest version of the JTS you have, which in this case is 4.0.3. Per our support matrix, you need Insight 1.1.1.2 to integrate with JTS 4.0.3. In this scenario, one other important note is that you must use the CLM 4.0.3 collateral in all of your development tools, regardless of what prior versions you are using. The 4.0.3 collateral comes bundled with previous versions of CLM collateral. So with the CLM 4.0.3 collateral, you would receive all the builds for prior versions (eg 4.0, 3.0.1.1, etc).


About the author

Cheng-Yee Lin (clin@us.ibm.com) is a development lead for the RRDI Development Team. Michael Fox (foxm@us.ibm.com) was the architect and a technical lead for the RRDI Development Team. He has been a technical lead for RRDI since its initial versions.

Feedback
Was this information helpful? Yes No 5 people rated this as helpful.