It's all about the answers!

Ask a question

Custom attributes of Duration type show same values


Roderick Thomas (661179) | asked Nov 01 '12, 3:08 p.m.
I have three attributes, all of type duration. When a value is entered into the first one, it's replicated into the other two types, even though the IDs of the attributes are unique. 

is this expected? How can this be resolved?

2 answers



permanent link
Lauren Hayward Schaefer (3.3k11327) | answered Nov 02 '12, 8:23 a.m.
JAZZ DEVELOPER
Hi Roderick,

I just tried this using my 4.0 eclipse client, and it's working as expected (typing in the first duration attribute does not replicate in the other two).  Can you double check in your editor presentation that the three attributes are referencing three different attributes?  I'm wondering if you accidentally used the same attribute but gave them different labels.

If that doesn't fix the problem for you, can you describe what client you're using (Eclipse or web), version, and the exact steps you followed to create the attributes and then add them to your editor presentation?

permanent link
David Castellanos (20686) | answered Nov 02 '12, 1:42 p.m.
I was able to reproduce the issue, see defect: https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=239658

Switch to 'Time Duration' instead of 'Time Estimates' for the 'Duration' attribute 'kind' in Editor Presentation for temp fix.

Your answer


Register or to post your answer.