It's all about the answers!

Ask a question

What is the best way to make a custom installation zip file for RTC Eclipse?


Jamie Berry (14012869) | asked Oct 30 '12, 6:27 p.m.
Hello,

  I have created some client side process extensions that need to be installed on all of our user's eclipse clients.  For people who already have the client installed, we can give them instructions on how to add an update site and install the new extension.  What I would like to do is replace our standard installation zip file (downloaded from jazz.net) with one that has the extension installed already so that new users don't have to take the extra step of updating their install right out of the box.

  I have tried zipping my jazz installation and then unzipping it in a different location, but that didn't appear to work correctly.  Does anyone have instructions on how to sanitize a local unzip installation to create a new install zip file?

Thank you for your help,

Jamie.

Accepted answer


permanent link
Ralph Schoon (57.7k23642) | answered Oct 31 '12, 3:58 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Jamie,

what I have done in the past is to download either the vanilla RTC Client that comes as zip, unzip it, install what you need and zip it using 7zip (just don't use any zip that ships with Windows, it has always had issues ith long path names that come with Eclipse/Jave package/jar naming).

This should work as far as I can tell. I think you can't zip the one that you install with Installation manager, but the original zip version should work. You can also install the RTC p2 install (if available for the version you use) into a plain unzipped Eclipse, install your plugins (there were issues with this approach in some 3.x versions). and zip that.

What issues are you experoienceing with using this approach?   
Jamie Berry selected this answer as the correct answer

Comments
Jamie Berry commented Oct 31 '12, 2:30 p.m.

Ralph,

  Thank you for the reply and the assurance on the process.  I guess I had some other issues going on that were interfering before.  I just tried starting with a fresh unzip of the base RTC Eclipse windows package, then I launched eclipse and without making any connections, installed my extension.  I then shut things down and went to the directory to modify the org.eclipse.ui.ide.prefs file to remove the latest workspace entry.  Finally, I zipped the directory.  When I tried unzipping the directory, everything seems to be working fine.

Thanks again.

Jamie.

Your answer


Register or to post your answer.