It's all about the answers!

Ask a question

Anyone have issues with Multiple values query on id attribute


Suresh Raman (9152329) | asked Aug 20 '12, 4:46 p.m.

Hi All,

We recently upgraded from 3.x to 4.0 on Red hat linux. I am trying to execute the ID query with multiple values and it returns only one record which is the first id. But it works perfectly in RTC eclipse client. I tried both IE8 and FF 10 ESR. Has anyone run into this issue.

Thanks,
Suresh

2 answers



permanent link
Daniel Pool (2644) | answered Aug 21 '12, 1:41 a.m.
JAZZ DEVELOPER
It just worked for me for RTC 4.0. Did you create the query in eclipse, save it and run it in the web UI? I guess if you are creating the query in the web UI you can double check that you are selecting "OR Any can match" in the web UI.

Comments
Suresh Raman commented Aug 21 '12, 10:34 a.m.

Daniel, I am using OR Any can match, but still the same problem. Also, when I save the query in eclipse and run it in web it works fine as long as I dont edit it. The moment I edit, the result displays only the first record. It is kind of odd. It is not a show stopper, but would like to get it fixed.


permanent link
Peter Kidwell (2389) | answered Nov 08 '12, 1:51 p.m.
Looks like there is a defect open for this, to be fixed in 4.0.1.  See Defect 230671 for details.

Your answer


Register or to post your answer.