It's all about the answers!

Ask a question

Lost Work Items !


John Schilt (6111822) | asked Aug 05 '12, 7:48 p.m.
Something wierd has happened in our Project : INFO5001 USYD

Last week I created a number of Teams (7x), Iterations (Semester 2 / Week 7 and Week 13), two work items of type Assignment (2712 and 2713) (I left these as Filed Against : unassigned).

I then created Deliverables for each of the teams and linked them to the Assignment 1 (and planned for Week 7 as well as Filed against each team).  So far so good !

Then I created an Iteration Plan for each Team.  Also added a few Work Items of type Task for good measure in each plan (Lab 1, Lab 2, Lab 3).   So far, so good.

I then write a tuturial to help students sign on and cope with creating new work items, etc - lots of screen shots.,

Then, later in the afternoon - one of the members of the team (Professor) created an additional two teams (and their categories) - and created new Deliverables.

However, when they tried to link to Assignment 1 (2712) - they could not find this.  (**)

I have now looked at this Project and am astounded !  I have run a range of queries trying to find these two work items : 2712 and 2713 (both of type Assignment).  NO WHERE TO BE SEEN !  Just dissappeared.

I reviewed the Plans that I created last week - they are still there - but no Assignment in the Roadmap view !  (Deliverable and Tasks are there)

What could cause two Work Items to dissappear ?  I have a class / lab tonight at University - be good to know what to do . . .

Any ideas / suggestions ?

(**) as I was not with the Professor when they created the two new Teams and Deliverables, I do not know what they did...  However, I would have at least expected to find these two (2712 and 2713) work items when running a number of queries

ps - I will most likely create another two work items and link them to the Deliverables . . .

Comments
John Schilt commented Aug 05 '12, 9:12 p.m. | edited Aug 06 '12, 9:56 a.m.

I should add a bit more information.

a) I tried to create a new work item of type Assignment - system gives me the following error message :

Could not save work item. CRJAZ1316I Illegal read access: User "schiltj" attempted to read item(s) having the following type(s): WorkItem.

b) I logged out - closed the browser (FireFox 14.0.1) and started FF and opened up this Project again. 

c) I created a few more tasks from the Iterations Plan display - just to see what happened....  this worked ok

d) I then opened up Deliverable - and looked at Links - and there it was under Parent  :  2712 : Assignment 1

Howeverm when I click on Assignment 1 - I get the following error :

Error opening work item. _YT-KJd0DEeGtLeqK4hJjaw

e) I then tried to create another assignment - Assignment 3, but again got the same error as above :

Could not save work item.

CRJAZ1316I Illegal read access:  User "schiltj" attempted to read item(s) having the following type(s): WorkItem.

f) I tried creating a work item of type Assignment in MS Explorer (8.0.6001) and same error as above.



I really hope someone has some suggestions.  Help !

Accepted answer


permanent link
Seth Packham (1.4k32213) | answered Aug 06 '12, 12:15 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
edited Aug 06 '12, 12:15 p.m.
@schiltj Hey John, I looked into your issue (I'm an Admin of the JazzHub servers) and can explain why your work items are not visible to you:

Your Assignment 2712 work item does exist, but the work item is restricted by category to only be visible to members of the INFO5001 USYD Team team area in your project. So, the work item will not even show up in queries to anyone who is not a member of that team area. The access restriction was most likely set in the Project Area editor > Work Item Categories page. I see there that work items that are Unassigned by category are associated with INFO5001 USYD Team and restricted to members of that team only. You can go into your Work Item Categories and unrestrict those work items.

Here is an article about how to manage work item access restriction:


I hope that all helps.
John Schilt selected this answer as the correct answer

Comments
John Schilt commented Aug 06 '12, 4:11 p.m.

Brilliant. Thanks. One of the professors must have ticked the Restriction check box by accident. I've fixed this and now every is as it should be. Thanks again, Seth !

Your answer


Register or to post your answer.