It's all about the answers!

Ask a question

Build engine windows service not starting

Jeff Foege (45256760) | asked Mar 22 '12, 6:20 p.m.
I can run the service in debug/run mode with no trouble at all. However when I install the service I get an authentication error.

I'm using the Java Service launcher v0.99.

java.lang.NoClassDefFoundError: com/roeschter/jsl/TelnetEcho
Caused by: java.lang.ClassNotFoundException: com.roeschter.jsl.TelnetEcho
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
Mar 22, 2012 4:00:13 PM org.apache.commons.httpclient.HttpMethodDirector isAuthenticationNeeded
INFO: Authentication requested but doAuthentication is disabled

Accepted answer

permanent link
Glenn Herbert (12657) | answered Mar 22 '12, 7:21 p.m.
It's not in these instructions but, as I found out through trial and error, you also have to comment out the following sections:

;Explicitely call this method and wait for it to return before setting the service to status running
;This method will be called before the main method

;Uncomment the premainclass to enable


I also had to change the jvmtype to be client (default is server) as my java jvm only had a client folder.
;Be careful what JVM is actullay installed and used before you report a bug on this feature.
Jeff Foege selected this answer as the correct answer

6 other answers

permanent link
Danny Müller (117619) | answered Jan 16 '14, 11:53 a.m.
I just installed the service for jsl64.exe on Windows Server 2012 and it processed a build request.
First I got the message Exception in thread: "Thread-1" but after commenting out the additional lines mentioned in this post it went fine.

permanent link
Jeff Foege (45256760) | answered Mar 22 '12, 6:35 p.m.
I was following these instructions:

When I run/debug the jsl.exe I do not get the message:
Mar 22, 2012 4:00:13 PM org.apache.commons.httpclient.HttpMethodDirector isAuthenticationNeeded
INFO: Authentication requested but doAuthentication is disabled

However when its run as a windows service it doesn't work.

permanent link
Jeff Foege (45256760) | answered Mar 26 '12, 6:35 p.m.
I wanted to thank your for your reply!! It did the trick! I'm not sure if it did anything but I also increased the string buffer.

I wanted to leave a comment on the wiki page that has these instructions but there wasn't a way to do it.

permanent link
Jeff Foege (45256760) | answered Mar 27 '12, 1:17 p.m.
Urgh! Why can't things ever be easy?

I'm now trying to install a service on a Win Server 2008 (64bit) machine and having trouble loading the JVM.dll. The only error I seem to be getting is 'Error loading: D:\Program Files\Java\jdk1.6.0_23\jre\bin\client\jvm.dll.

I verified the path to the file is correct.

Has anyone else been able to get this to work on a 64bit machine?

permanent link
Jeff Foege (45256760) | answered Mar 27 '12, 1:21 p.m.
There might be a problem using the jsl64.exe. Running the windows service as 32bit seems to work just fine.

permanent link
Robert Carter (42927987) | answered Apr 17 '14, 9:25 a.m.
Environment Windows 7, JSL v0.99o, RTC 4.0.6

I followed the WiKi instructions and when starting I get this error message:

Now starting JVM
:1397740935: java starting 1
:1397740936: Searching for JVM path in ini file
:8344095282464544136: Searching for co-located JVM
:8344095282464544136: Searching JVM in sub directory
:8344095282464544136: Searching JVM in registry
Error opening registry key 'Software\JavaSoft\Java Runtime Environment'

Your answer

Register or to post your answer.