It's all about the answers!

Ask a question

getting balnk (feilds are not visible) WI after customizing


shruti joshi (1002833) | asked Mar 20 '12, 2:50 a.m.
Hi

I am using RTC 3.0.1. I have created a new workitem type in CCM, I am getting a blank WI, when I clicked on new WI type.

Can some body help me in this???

Thanks
Shruti

7 answers



permanent link
Ralph Schoon (58.0k23642) | answered Mar 20 '12, 3:47 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi,

there is too few information to really understand what is happening. The only thing I can think of right now is, that you have to create editor presentations and bind them to the type/workflow.

permanent link
shruti joshi (1002833) | answered Mar 20 '12, 5:41 a.m.
Hi.

I have already created respective WI-workflow, even after binding it I am not getting a preview of newly created WI!!!!


Do I need to enable some properties after creating new WI????
Or
I did something wrong while creating new WI????


Thanks
Shruti

permanent link
Ralph Schoon (58.0k23642) | answered Mar 20 '12, 6:09 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi,

I said "editor presentations" because they provide the UI editors.

permanent link
shruti joshi (1002833) | answered Mar 20 '12, 8:02 a.m.
Hi Ralph,

I have created a new WI as I mentioned in my previous posts.... Now their is a new error popping up in Permissions tab of WI, Following is the error message:

" Error: dojo.data.ItemFileReadStore: Invalid item argument"

Like:

To reproduce:

Manage project areas -> Pick project -> Permissions -> Team Configuration

The following displays for a while:

Loading Permitted Actions .......

Then an error dialog says:

Error: dojo.data.ItemFileReadStore: Invalid item argument

Can you help me asap???? Because of this error my team is not able to deliver their projects in RTC 3.0.1....

Thanks
Shruti

permanent link
Ralph Schoon (58.0k23642) | answered Mar 20 '12, 8:13 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I would suggest to open a PMR with support.

permanent link
shruti joshi (1002833) | answered Mar 21 '12, 6:43 a.m.
Hi Ralph,

Thanks for your support for" Error: dojo.data.ItemFileReadStore: Invalid item argument" this error has been solved by restarting Jazz team server.

But I am stuck in getting a preview of Newly created WI in an application.

I have checked every thing including editor presentations and binding of it... still I am not getting any fields in WI. Have no Idea why it is not showing me any fields in that.

Is their is any other way to create a new type of WI??? or can I duplicate the original one and edit that duplicated WI according to me???? If yes then please guide me for the same....

Thanks
Shruti

permanent link
Ralph Schoon (58.0k23642) | answered Mar 21 '12, 7:57 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Shruti,

before you try this in a production server you should familiarize yourself with it on a test server. You can easily setup one e.g. using the 10 free licenses or any other license you have.

I am not sure what your problem is.

You create a new work item type, you bind it to a workflow and then you create/assign the editor presentation(s). You need the Work Item Editor to be able to create a work item in the web UI or in Eclipse using the menu.

https://jazz.net/library/article/565 talks about all this in details.

Your answer


Register or to post your answer.