It's all about the answers!

Ask a question

Problem using existing RTC server with RAM 7.5


Greg Hodgkinson (2092117) | asked Feb 25 '11, 3:15 a.m.
I've installed RAM 7.5 and busy working through the setup.

I've selected to use an existing RTC server, and specified the path and users for User Management and Project Area Management (Part 4 of setup).

When I click on Configure server I get an error saying "CRRAM3026E - The user jazzadmin information in Rational Team Concert is not configured correctly".

In the logs it says "The login was successful, but the user jazzadmin cannot be found on the list of active users in the User Management section of the Team Concert server".

I have logged into RTC with this user and verified that it appears as an active user with the following repository permissions: JazzAdmins, JazzDWAdmins, JazzGuests, JazzUsers.

Also the user has a developer license assigned.

Any ideas?

8 answers



permanent link
Greg Hodgkinson (2092117) | answered Feb 25 '11, 4:56 a.m.
I've just upgraded to 7.5.0.1 and still getting the same error although the message has been expanded to also say "For more information, see the Rational Asset Manager help system."

So I'm going to go root around in the help to see if I can find the answer.

permanent link
Greg Hodgkinson (2092117) | answered Feb 25 '11, 5:13 a.m.
Help file says the following:

CRRAM 3026 E


The user {0} information in Rational Team Concert is not configured correctly.
Explanation
The user that Rational Asset Manager is using to access Rational Team Concert is not a registered user of Rational Team Concert.
User response
In the server setup application, repeat the steps to configure lifecycle management. If the error persists, open the WebSphere Application Server server logs directory and check jazz.log. You can find the logs at the following location: websphere_install_dir/profiles/profileName/logs, where websphere_install_dir is the name of the directory where you installed WebSphere Application Server, and profileName is the name of the profile.


I looked in the log file and found...

ERROR CRRAM901E: RAM - The login was successful, but the user jazzadmin cannot be found on the list of active users in the User Management section of the Team Concert server.


Doesn't tell me any more than I already knew.

permanent link
Greg Hodgkinson (2092117) | answered Feb 25 '11, 5:23 a.m.
Could this error be caused by not getting the users group(s) back from LDAP?

In 'Part 2: Map LDAP Authentication Properties' I've noticed that the "Search Groups" button doesn't return anything although the "Test the Mapping" returns file.

permanent link
Greg Hodgkinson (2092117) | answered Feb 25 '11, 5:57 a.m.
I've fixed my LDAP issue but still getting the same problem when I try to "Configure server" in Part 4, step 3.

permanent link
Rajasimhan Mandayam (381134) | answered Feb 25 '11, 10:57 a.m.
JAZZ DEVELOPER
what happens when you click on Configure Server button

if you still see the same error, can you try the jazz url in a browser and see if jazz is working,

if not can you attach the logs of the server, profileName\logs folder

permanent link
Greg Hodgkinson (2092117) | answered Feb 26 '11, 4:52 a.m.
When I click Configure Server I get the following:

CRRAM901E: RAM - The login was successful, but the user jazzadmin cannot be found on the list of active users in the User Management section of the Team Concert server. For more information, see the Rational Asset Manager help system.


I don't see a way to attach log files to a posting - In any case I looked in the logs and the only message there was:


ERROR CRRAM901E: RAM - The login was successful, but the user jazzadmin cannot be found on the list of active users in the User Management section of the Team Concert server.

permanent link
Robert Graziano (6) | answered Jun 24 '11, 3:16 p.m.
When I click Configure Server I get the following:

CRRAM901E: RAM - The login was successful, but the user jazzadmin cannot be found on the list of active users in the User Management section of the Team Concert server. For more information, see the Rational Asset Manager help system.


I don't see a way to attach log files to a posting - In any case I looked in the logs and the only message there was:


ERROR CRRAM901E: RAM - The login was successful, but the user jazzadmin cannot be found on the list of active users in the User Management section of the Team Concert server.




Hello,

We were having the same problem here. I'm a JazzAdmin on RTC (authenticating via LDAP), but while RAM recognizes me as an RTC user and my AD configuration to RAM works well (recognizes different users and groups), RAM 7.5 still reports that "user xxxx cannot be found on the list of active users in the User Management section of the Team Concert server." For the record, I am a member of both the JazzAdmin and the JazzUsers groups (yes, it's redundant). Would this make any difference?

Thanks,
Robert ...

permanent link
Rajasimhan Mandayam (381134) | answered Jun 24 '11, 5:48 p.m.
JAZZ DEVELOPER
When I click Configure Server I get the following:

CRRAM901E: RAM - The login was successful, but the user jazzadmin cannot be found on the list of active users in the User Management section of the Team Concert server. For more information, see the Rational Asset Manager help system.


I don't see a way to attach log files to a posting - In any case I looked in the logs and the only message there was:


ERROR CRRAM901E: RAM - The login was successful, but the user jazzadmin cannot be found on the list of active users in the User Management section of the Team Concert server.




Hello,

We were having the same problem here. I'm a JazzAdmin on RTC (authenticating via LDAP), but while RAM recognizes me as an RTC user and my AD configuration to RAM works well (recognizes different users and groups), RAM 7.5 still reports that "user xxxx cannot be found on the list of active users in the User Management section of the Team Concert server." For the record, I am a member of both the JazzAdmin and the JazzUsers groups (yes, it's redundant). Would this make any difference?

Thanks,
Robert ...


Are you using an existing RTC server also.

If so, you can probably finish this step manually by following these steps.

http://publib.boulder.ibm.com/infocenter/ramhelp/v7r5m0/topic/com.ibm.ram.installguide.doc/topics/t_config_rtc_manual.html

Your answer


Register or to post your answer.