RegisterLog In to Jazz.net dW

It's all about the answers!

Ask a question

Version mismach whn conecting to JTS from RTC Eclipse client


Dinesh Kumar (2.8k313) | asked Jan 04 '11, 2:24 a.m.
JAZZ DEVELOPER
I encountered a strange problem. I installed Jazz Team Server a few weeks ago and today i tried installing RTC. Since the installer was giving some errors beyond my understanding, i downloaded a fresh copy of the Web installer and completed the installation of RTC. Now when i launch the Eclipse client and try connecting to JTS, below error is what i see:

</error>
The server you are connecting to is older than your client and not compatible. Please contact your system administrator to determine the server version and download the appropriate client.

Current Client Version: 3.0

Your client is not compatible with the server at ibmdinesh.in.ibm.com. Update your client from https://jazz.net/downloads/rational-team-concert.
</error>

JTS Version : RJF-I20101112-0630
RTC Version : RTC-I20101112-1731


I tried both update/ modify options and they both say there are no more updates for either RTC or JTS.

8 answers



link
Anthony Kesterton (7.2k21145) | answered Jan 04 '11, 6:34 a.m.
JAZZ DEVELOPER
I encountered a strange problem. I installed Jazz Team Server a few weeks ago and today i tried installing RTC. Since the installer was giving some errors beyond my understanding, i downloaded a fresh copy of the Web installer and completed the installation of RTC. Now when i launch the Eclipse client and try connecting to JTS, below error is what i see:

</error>
The server you are connecting to is older than your client and not compatible. Please contact your system administrator to determine the server version and download the appropriate client.

Current Client Version: 3.0

Your client is not compatible with the server at ibmdinesh.in.ibm.com. Update your client from https://jazz.net/downloads/rational-team-concert.
</error>

JTS Version : RJF-I20101112-0630
RTC Version : RTC-I20101112-1731


I tried both update/ modify options and they both say there are no more updates for either RTC or JTS.


There is a chance that your Eclipse/RTC local workspace is confused. Can you try again with a new workspace?

regards

anthony

link
Dinesh Kumar (2.8k313) | answered Jan 04 '11, 7:31 a.m.
JAZZ DEVELOPER
Nope, the same error appears with the new workspace as well.

I am feeling that reinstalling is the only way out... any other suggestions?

link
Anthony Kesterton (7.2k21145) | answered Jan 04 '11, 8:33 a.m.
JAZZ DEVELOPER
Nope, the same error appears with the new workspace as well.

I am feeling that reinstalling is the only way out... any other suggestions?


Not really....it might be quicker in the long run to reinstall. I am concerned about the errors in the initial install - if you see the same problems again - please record the messages and post here.

When you uninstall - unless you have info you want to keep - after the IM has uninstalled - delete all the directories too (on my machine, that would be on c:\program files\ibm\JazzTeamServer and c:\program files\ibm\TeamConcert and c:\program files\ibm\TeamConcertBuild).

Also - let us know what OS you are installing on.

regards
anthony

link
Dinesh Kumar (2.8k313) | answered Jan 04 '11, 9:07 a.m.
JAZZ DEVELOPER
Thanks for your inputs.

I feel it was becoz of the difference in the build numbers
JTS Version : RJF-I20101112-0630
RTC Version : RTC-I20101112-1731

RTC being 1731 which is higher than 0630 of JTS.

However, what i was wondering is if RTC should really look at that level to get going. Version number being the same (3.0 ) should have kept it running, this is more desirable.

I am going for the reinstall now.

BTW, I am working with Win XP SP3.

link
Tim Mok (5.6k28) | answered Jan 04 '11, 1:36 p.m.
JAZZ DEVELOPER
What is the URI that you're using for the connection to the server? You may be connecting to /jts when you should connect to the context specified for RTC during server setup.

link
hugo scavino (6) | answered Jun 20 '11, 1:26 p.m.
What is the URI that you're using for the connection to the server? You may be connecting to /jts when you should connect to the context specified for RTC during server setup.


Not sure if you have the same situation but I went back and confirmed my new RTC server was excluded from the HTTP/HTTPS proxy. It was good after I updated the exclusion list. I had to switch to manual and all went well. Very frustrating after 3 days.

link
Olivier Béghain (889) | answered Mar 28 '12, 3:22 p.m.
Hello,

I'm currently encountering the same problem.

I've a JTS installed (release 3.0.1.2 20111207-1350) and try to connect with a RTC client on windows and MacOSX (release 3.0.1.2 20111208-1025). Although both client and server are 3.0.1.2, the problem occurs. I'm going to try with a RTC client 3.0.1.1.

Regards,
Olivier Bghain

link
Olivier Béghain (889) | answered Mar 28 '12, 5:58 p.m.
Hi,

Problem is solved.

I made a mistake when specifyig the URI in the RTC client. Instead of specifying <server>/ccm I specified <server>jts/ccm. To the rror message isn't reflecting the real problem.

Regards,
Olivier.

Hello,

I'm currently encountering the same problem.

I've a JTS installed (release 3.0.1.2 20111207-1350) and try to connect with a RTC client on windows and MacOSX (release 3.0.1.2 20111208-1025). Although both client and server are 3.0.1.2, the problem occurs. I'm going to try with a RTC client 3.0.1.1.

Regards,
Olivier Bghain

Your answer


Register or log in to post your answer.