It's all about the answers!

Ask a question

Error in workshop setup EWM version 7.0.2

Carlos Isacovich (5919) | asked Jul 06, 9:34 a.m.
Trying to execute WorkshopSetup.bat with the CLASSPATH system environment variable defined as:
C:\EWM7.02\Installs\WorkshopSetup>ECHO %CLASSPATH%

I get the following error:

C:\EWM7.02\Installs\WorkshopSetup>set JAVA_HOME=..\JazzTeamServer\server\jre

C:\EWM7.02\Installs\WorkshopSetup>set PLAIN_JAVA=../PlainJavaAPI

C:\EWM7.02\Installs\WorkshopSetup>set REPOSITORY="https://localhost:9443/ccm"

C:\EWM7.02\Installs\WorkshopSetup>set USERID="myadmin"

C:\EWM7.02\Installs\WorkshopSetup>set PASSWORD="myadmin"

C:\EWM7.02\Installs\WorkshopSetup>..\JazzTeamServer\server\jre\bin\java -cp ../PlainJavaAPI/*;./*
rverSetup "https://localhost:9443/ccm" "myadmin" "myadmin"
Error: A JNI error has occurred, please check your installation and try again
Excepción en hebra "main"# START NON-TRANSLATABLEjava.lang.NoClassDefFoundError:
        at java.lang.J9VMInternals.prepareClassImpl(Native Method)
        at java.lang.J9VMInternals.prepare(
        at java.lang.Class.getMethodHelper(
        at java.lang.Class.getMethod(
        at sun.launcher.LauncherHelper.validateMainClass(
        at sun.launcher.LauncherHelper.checkAndLoadMain(
Caused by: java.lang.ClassNotFoundException:
        at java.lang.ClassLoader.loadClassHelper(
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        ... 6 more

Carlos Isacovich commented Jul 06, 9:47 a.m.
Replacing by WorkshopSetup.jar I get
C:\EWM7.02\Installs\WorkshopSetup>..\JazzTeamServer\server\jre\bin\java -cp ../PlainJavaAPI/*;./* WorkshopSetup.jar "https://local
host:9443/ccm" "myadmin" "myadmin"
Error: No se ha podido encontrar o cargar la clase principal WorkshopSetup.jar

Accepted answer

permanent link
Ralph Schoon (62.7k33643) | answered Jul 06, 10:45 a.m.

 I have done this for 7.0.2 and it worked, if following the PDF. Make sure to use the Java that ships with the EWM version. You do not have to do anything to the batch file. The one below is the one that worked for me.

set JAVA_HOME=..\JazzTeamServer\server\jre
set PLAIN_JAVA=../PlainJavaAPI
set REPOSITORY="https://localhost:9443/ccm"
set USERID="myadmin"
set PASSWORD="myadmin"


Carlos Isacovich selected this answer as the correct answer

Carlos Isacovich commented Jul 06, 4:44 p.m.
Hi Ralph.

Thanks for your quick answer. I followed strictly the RTC700ExtPoT.pdf instructions, replacing only RTC6.0.2 folder by EWM7.02 one.
When originally download the workshop files on June 26 I make a mistake downloading the RTC Extension Workshop setup tool, because I downloaded the version 4 instead version 7. I downloaded today the correct one, but it leads to the error reported.
Is it possible that the error is related with differences between 7.0.2 and 7.0.2SR1 versions? I tried to download again all the files, but I cannot get access to All Downloads 7.0.2 versions, because the URL is automatically redirected to 7.0.2SR1. But in the 7.0.2SR1 page, all the workshop files appear as "coming soon".

Ralph Schoon commented Jul 07, 2:10 a.m.

Try clearing your browser cache and browsing history. There is an odd issue that causes the Coming Soon and can likely be overcome doing this.

The Extensions Workshop has not been changed for the 7.0.2 SR1.  

Carlos Isacovich commented Jul 07, 8:30 a.m.

Thank you Ralph. I can access to the files cleaning the history. I'll reinstall the workshop from scratch and comment results.

Your answer

Register or to post your answer.