It's all about the answers!

Ask a question

Error in upgrading DNG from CLM6.0.6.1 to ELM 7.0.2


Sunil Deshpande (131) | asked Feb 26, 9:12 a.m.

 Hello,

     Am getting error in upgrading DNG from CLM 6.0.6.1 to ELM 7.0.2.
Applied iFix010 on ELM 7.0.2 and for CLM 6.0.6.1 we have used iFix023.

We have ran the 
"JazzInstallDir/Sever>upgrade\rm\rm_upgrade.bat -oldApplicationHome "D:\CLM_Installs\IBM\CLM_6.0.6.1_Liberty\IBM\JazzTeamServer6061\server\conf" -newJTSHome "D:\CLM_Installs\IBM\ELM_7.0.2_Liberty\IBM\JazzTeamServer702\server\conf" -jtsRepositoryUrl https://hostname.org.net:9443/jts -adminUserId ** -adminPassword ** "

The error which we are getting is as below.

On DNG when we ran the upgrade command, In Export link Validity data command it says as below. <o:p> </o:p>

<o:p>   </o:p>

CRJAZ1356E  The repotools command could not connect to the following server ‘https://hostname.org.net:9443/jts’ <o:p> </o:p>

<o:p>  (Same URL which we used in upgrade command) </o:p>

The rm upgrade failed at step 1. <o:p> </o:p>

<o:p>   </o:p> We followed the jazz.net link

<o:p> </o:p>

<o:p>   </o:p>

https://jazz.net/wiki/bin/view/Deployment/MigratingTheRequirementsManagementLinkValidityData%22 <o:p> </o:p>

<o:p>   </o:p>

But still we were unable to cross the step. <o:p> </o:p>

Could anyone help on this.


Thanks,

Sunil Deshapnde

Accepted answer


permanent link
Bartosz Chrabski (3.3k12242) | answered Feb 26, 11:26 a.m.

 Sunil,


Links are migrated and no information is lost but exception is link validity.

If You have links validity turned on this information will be lost if you will use parameter that I gave you

You are right there is no client similar to DNG for ETM..

Links will be migrated.

Sunil Deshpande selected this answer as the correct answer

Comments
Sunil Deshpande commented Feb 26, 11:28 a.m.

 Could you please share us the Command to run the upgrade


Bartosz Chrabski commented Feb 26, 11:33 a.m.

rm_upgrade.bat -oldApplicationHome old_RM_install_dir\server\conf -newJTSHome new_RM_install_dir\server\conf -migrateLinkValidity no

One other answer



permanent link
Bartosz Chrabski (3.3k12242) | answered Feb 26, 11:17 a.m.

 Sunil,


Please read documentation about the upgrade process from 6.0.X to 7.0.X. 

If You use link validity in the step which is failing you need to turn on JTS server with LDX and migrate link validity data.

If You do not use link validity then add -migrateLinkValidity no and you wont get this error.



Comments
Sunil Deshpande commented Feb 26, 11:21 a.m.

  Thanks Bartosz for your answer.


By making -migrateLinkValidity no,. Does it affect any of the links? 

Your answer


Register or to post your answer.