It's all about the answers!

Ask a question

Replace Schema in RPE Document Studio


Chidambaram L (2093365) | asked Oct 05 '21, 1:33 p.m.
edited Oct 05 '21, 10:36 p.m.

I am using RPE Document Studio Version 6.0.6.1 32-bit. Windows 10 6.4-bit OS.

Replace Schema option in Data Source Configuration worked until last week. I am using Generic XML Schema.
Surprising, this option is not working in the last 2 days, even though there is only one new node added to the new schema. 
Error dialog does not show any message.
Error message

Reinstallation of RPE Document Studio did not help.
I have also cleared the temp files from "C:\Users\clakshm\AppData\Local\Temp\RPE\temp"
"Open Schema in Editor" opens the schema. Changes done in the editor does not reflect in Data Source View.
rpe.log also not print any entry in debug mode.

For each change in Schema, I am now creating a fresh dta template to test the schema changes.

Issue noticed in the following versions:
Rational Publishing Engine Document Studio
Version 6.0.6.1 
Build 20190326_1938

Rational Publishing Engine Document Studio
Version 6.0.6.1 
Build 20201211_0134


Comments
Chidambaram L commented Oct 06 '21, 6:58 a.m.

I have deleted the following folders, but the problem is not resolved.

  1. "C:\Users\clakshm\AppData\Local\Temp\RPE\temp"
  2. "@user.home/Application Data/IBM/Rational/RPE_20201211_0134". This is a folder defined in rpe-studio.ini.
What are the registry entries related to RPE, that I can flush after uninstallation.

One answer



permanent link
Subramanya Prasad Pilar (4.5k14) | answered Oct 06 '21, 8:24 a.m.
Clearing workspace or registry does or make any difference in this case.
If you are choosing "Replace Schema...", try providing http URL (as there can be multiple xsd files). If you are using schema editor, do you see "Schema is not compatible with the template." in the console? In that case, try editing in a new/blank template.

Your answer


Register or to post your answer.