It's all about the answers!

Ask a question

RTC Extension -7.0.2


Girish Chandra (852842) | asked Feb 08, 11:41 a.m.
Test the Jetty based debug server launch: I am not able to launch the jetty Server with all the Junit passed.

RTC Version 7.0.2 , Eclipse Version 2020-06 , Java - 1.8

Operating System : 7.0.2

Error Log :
!ENTRY org.eclipse.emf.ecore 2 0 2021-02-08 21:31:25.448
!MESSAGE Both 'com.ibm.team.git.common' and 'com.ibm.team.git.common' register a package for 'com.ibm.team.git.model.dto'

!ENTRY com.ibm.team.feed.ui 4 0 2021-02-08 21:31:25.670
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.ibm.team.feed.ui [114]
  Unresolved requirement: Require-Bundle: org.eclipse.ui
    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.1.v20141002-1150"; singleton:="true"
       org.eclipse.ui [716]
         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.2.v20150204-1030"; singleton:="true"
              org.eclipse.ui.workbench [724]
                Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
                  -> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.12.2.v20150204-1353"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
                     org.eclipse.e4.ui.workbench.renderers.swt [631]
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.12.100.v20141126-1150"; singleton:="true"
                            org.eclipse.e4.ui.workbench.swt [633]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.css.core; bundle-version="0.9.0"
                                -> Bundle-SymbolicName: org.eclipse.e4.ui.css.core; bundle-version="0.10.100.v20140424-2042"; singleton:="true"
                                   org.eclipse.e4.ui.css.core [622]
                                     Unresolved requirement: Require-Bundle: org.apache.batik.css; bundle-version="1.7.0"

    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


    

Accepted answer


permanent link
Girish Chandra (852842) | answered Feb 09, 9:54 a.m.
Dear Ralph ,
Thanks for your reply. I am able to setup with 7.0.2.
I was trying to setup  using the jazz team server in different machine with Oracle DB , later installed on same machine where I was setting up  Eclipse -Development.Completed it . Thank you .
Ralph Schoon selected this answer as the correct answer

One other answer



permanent link
Ralph Schoon (57.7k23642) | answered Feb 09, 2:42 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Feb 09, 2:43 a.m.

 I have only tried 7.0.1 and I remember I had to do some changes to the server launches.

Anyway. Can you create a support case? 

Use your Jazz.net credentials.


Comments
Ralph Schoon commented Feb 09, 4:01 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I would suggest to use 7.0.1 or 6.0.6.1 for the moment, unless you really require new API from 7.0.2. The API has been very stable so far. 

Your answer


Register or to post your answer.