It's all about the answers!

Ask a question

How do you get BIRT tools to work with RTC 6.0.6?


Bill Taylor (1441323) | asked Oct 15 '19, 1:32 p.m.
edited Oct 15 '19, 1:34 p.m.
I recently installed RTC 6.0.6 into my Windows 10 environment. I the used the "Install New Software" menu item to install the BIRT tools from the Neon (IDE 4.6) site. When I launch the "Report Design" perspective, I notice that the "Preview" tab is missing (compare to the IDE 3.5 equivalent). This seems a retrograde step.

More seriously, when I try to run a report, its "Project Area2 parameter dropdown is not populated.

If i create a data set based on the "PROJECT_AREA" data set, select the "PROJECT_AREA_NAM" column and click on the "Preview results" button I get an error:

org.eclipse.birt.data.engine.odaconsumer.OdaDataException: Cannot execute the statement.

    org.eclipse.datatools.connectivity.oda.OdaException: T24


What am I doing wrong?

One answer



permanent link
Ian Wark (7912944) | answered Oct 16 '19, 3:03 a.m.
I believe the issue may be your version of the BIRT tools. I think you may need to stick with Eclipse v4.4.x and the Luna Eclipse version of the BIRT tools for it to work with RTC.

Please check this document for some steps.


Comments
Ian Wark commented Oct 16 '19, 3:22 a.m.

I checked and RTC server 6.0.3 and up uses BIRT 4.4. So you need to integrate with that.

https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=411606


Bill Taylor commented Oct 17 '19, 11:25 a.m.

Thanks Ian for your response. I have installed the RTC 6.0.6 4.4 IDE and the Luna BIRT tools but I get exactly the same problem and error message. I even tried installing RTC 6.0.2 3.6 IDE with the same result! The report works fine when installed. The environment is newly created Windows 10 and I am using Derby.

Your answer


Register or to post your answer.