It's all about the answers!

Ask a question

[closed] Installed RTC on my local machine - Email configuration error


Vijay M (113) | asked Aug 27 '19, 1:44 p.m.
closed Sep 18 '19, 2:43 a.m. by Ralph Schoon (59.7k23643)

 I installed a local copy of RTC 6.0.6 as a localhost on windows 10. I am using the default setting of derby db and websphere liberty server, which are express setup.  I tried to configure the email server using smtp.gmail.com:465, to send email.  Can someone help me with how to configure this.  I keep getting an error - so I read and tried the openssl s_clinet configuration to keytool the java cert with no success. Is there a step I am missing? Here are the steps i used

1) echo q | openssl s_client -showcerts -connect smtp.gmail.com:465 | openssl x509 -outform DER > smtp_google.der
2) keytool import the certificate. liberty_install_path\liberty\servers\clm\resources\security. Import was successful.
3) stop and start liberty server
4) Send a test email

getting an error - Could not connect to SMTP host: smtp.gmail.com, port: 465, response: -1

Can someone help how I can configure an email send - so I can do some RTC evaluation and learn.  Thank you in advance



Comments
Krzysztof Kaźmierczyk commented Sep 04 '19, 6:44 a.m.
Hi Vijay,

Do you have any error in jts.log and ccm.log at this time?

The question has been closed for the following reason: "Problem is not reproducible or outdated" by rschoon Sep 18 '19, 2:43 a.m.

One answer



permanent link
Ralph Schoon (59.7k23643) | answered Sep 18 '19, 2:43 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 Unless you want to share more error information, I will close this question.


In general I would suggest you install a local mail server e.g. https://www.hmailserver.com/ to have more control. Get that working first and have it work with a mail client such as Thunderbird so you can send and receive mail. Once that works, try to configure the CLM servers. That has always worked best for me.