It's all about the answers!

Ask a question

What do I have to do to use selfmade Java-Methods in a RPE-Template deployed in RQM on a WAS?

Christopher Seidel (136) | asked Dec 13 '18, 8:15 a.m.
edited Dec 18 '18, 3:29 a.m. by Muralidhar Rajagopal (10114)


I have the following situation. I have a RPE-Template, in which i use the RQMurlUtility.jar from IBM amongst other things. To use the JAR, I had just to place it inside the "<RPE_HOME>\jre\lib\ext" and it worked fine. In the next step i deployed it into RQM and it also worked fine, when I placed the JAR in "<JTS_HOME>\server\jre\lib\ext". Everything works fine when using the "WebSphere Application Server Liberty" but now comes the problem.

I want to deploy the template in a RQM which is running on a WebSphere Application Server (WAS). To just place the JAR-File in the mentioned path doesn't work. So i checked the options in WAS and found out that the JARs must probably be loaded by a class loader of the WAS. I created a Shared Library, made a reference to RQM and
restarted the WAS. When i checked the class loader viewer, the JAR is loaded but not the classes inside the JAR.

First I thought I had to modify the Manifest-File somehow but then i tried to load other JAR-Files which are already loaded by other class loaders and it also didn't work. I wonder what i have to do to use selfmade Java-Methods in a RPE-Template deployed in RQM on a WAS.

Additional Information
RPE and JTS Versions are 6.0.6
WAS Version is
Installed Features on WAS:
- IBM 64-bit Websphere SDK for Java
- WebSphere Application Server Full Profile
- ...

In advance thanks for your help and time.

Subramanya Prasad Pilar commented Dec 14 '18, 5:21 a.m.

This should be some issue with WAS. How are you calling the methods - within "JavaScript Code" element through "Command" property?

Christopher Seidel commented Dec 14 '18, 9:30 a.m.

I am calling the Java-Methods directly for example:
var reader = new;


I am not executing Main-Classes via commandline calls.

Be the first one to answer this question!

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.