It's all about the answers!

Ask a question

#RPE #DNG How can I display embedded images in the primary text column in a word document?


Emely Pi (155) | asked Jun 01 '18, 5:44 a.m.
Hi,
I have attributes in my primary text column which include an embedded image or diagram. So far, everytime I try to read out this column I get back nothing. Not even an attribute which just consists of text. I think that there might be an issue with the configuration of my data sources.
This is my URI: https://myserver:myport/rm/publish/resources?moduleURI=_BWG9gVj6Eei-rPLJSd9w-A&maximiseEmbeds=true

I can read out any attribute from any column but from the primary text and the content columns. There I get nothing.

Thank in advance!

Accepted answer


permanent link
Subramanya Prasad Pilar (3.9k14) | answered Jun 01 '18, 11:07 a.m.
edited Jun 01 '18, 11:09 a.m.

You should use "text" (instead of "resources") schema. To get richtTextBody, the data source URI should be
https://myserver:myport/rm/publish/text?moduleURI=_BWG9gVj6Eei-rPLJSd9w-A&maximiseEmbeds=true

Emely Pi selected this answer as the correct answer

Comments
Emely Pi commented Jun 01 '18, 11:13 a.m.

Ok, thanks

2 other answers



permanent link
David Reilly (697) | answered Jun 01 '18, 10:11 a.m.

Emely -


Try using "dataSource/artifact/content/text/richtTextBody/div". This should be documented in one of the example templates provided with the installation of RPE: DNG_Resources.dta.

I don't know what you mean by Primary Text column in a word document. With more details, I'm sure myself or someone else on the forum would be willing to help. 

David


Comments
Emely Pi commented Jun 01 '18, 10:25 a.m.
Hi,
thanks for the answer. I tried using "dataSource/artifact/content/text/richtTextBody/div" and nothing was printed into my word document. I also tried "dataSource/artifact/primaryText" with the same result. This is why I am thinking something is wrong with my URI.

permanent link
Subramanya Prasad Pilar (3.9k14) | answered Jun 01 '18, 10:52 a.m.
edited Jun 01 '18, 10:53 a.m.

Are you using Data Source Configuration element in the template to configure data source URI dynamically? If so, appending maximiseEmbeds=true parameter to the "URI" (of Data Source Configuration element) should work.


Comments
Emely Pi commented Jun 01 '18, 11:00 a.m.

No, I don't use the data source configuration element. I just use the data source from the data source view.

Your answer


Register or to post your answer.