It's all about the answers!

Ask a question

Any other ways "Attribute not set" message can appear in RTC besides a pre-condition for a required field?


Kim Williams (5620) | asked Jan 17 '18, 5:57 a.m.

Our task work item only requires that the Summary field be set for any its states.  I create a task, add the summary field and save.  When I switch to the next state, I get a message that the "owner" field is not set.  Besides the operational behaviors section where required fields can be set up, is there some other reason that this message would be coming up?  Everything I have looked at in my process template says that the owner field is not a required field for our task work item.  I'm quite perplexed.

Accepted answer


permanent link
Ralph Schoon (60.9k33643) | answered Jan 17 '18, 8:38 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

What I have seen is, that users and administrators/project area administrators are unaware of the full capabilities of RTC and where you actually can configure the process. They did not look at all the places and missed the one thing that they where looking for. It is also important to mention the version of the client and server and what client was used.

Required attributes are configurable in
- Conditions (using a pre-condition)
- Pre-conditions
- Required attributes - which is a precondition and there are several with different names to be set for 
-- Work Item Save Server
-- Work Item Save Client

Operational Behavior can be configured
- On Project Area Level
- On Team Area Level
- For Iterations or Iteration types



Kim Williams selected this answer as the correct answer

Comments
Kim Williams commented Jan 18 '18, 1:02 p.m.

Thank-you for the information.  It was helpful.

Your answer


Register or to post your answer.