It's all about the answers!

Ask a question

BIRT reports developed in eclipse 3.6 don't work anymore


Milan Krivic (9807158130) | asked Jan 23 '17, 8:52 a.m.

 Hi,

after we migrated our CLM from version 6.0.1 to 6.0.3, our BIRT report doesn't work anymore.
We used approach which is not supported out of the box.

We modified "org.eclipse.birt.report.data.oda.jdbc_2.6.2.r262_v20110127.jar" file and added necessary *.jar files for accessing live tables and DWH trough BIRT. We were very satisfied with this solution, but when we upgraded CLM from 6.0.1 to 6.0.3, it stopped working. File "org.eclipse.birt.report.data.oda.jdbc_2.6.2.r262_v20110127.jar" doesn't exist anymore at jazz/ccm update site plugins folder. Now, there is a new one called "org.eclipse.birt.report.data.oda.jdbc_4.4.2.v201410272105.jar". 

From my point of view, it seems that existing birt reports need to be upgraded to new birt report designer 4.4.2..

Is there any instructions how to do that? which plugins must be downloaded exactly...?

Regards,
milan

3 answers



permanent link
Kevin Ramer (4.4k6160180) | answered Jan 23 '17, 4:34 p.m.

The Knowledge Center section "Installing BIRT Tools" have a small table ( I checked 6.0.2 and 6.0.3 )

[ copy ]
To ensure that the component versions are compatible with Rational Team Concert, you must download them from the Eclipse website and install them manually into your product installation directory.

Table 1.
Rational Team Concert BIRT DTP EMF GEF WTP
Versions 4.0 and later 2.6.2 1.8.2 2.6.2 3.6.2 3.2.3

Unfortunately, it says "Before you begin"...

Important: You must use the Client for Eclipse 3.6.x IDE , which ....



permanent link
Don Yang (7.2k2189125) | answered Jan 24 '17, 10:26 p.m.

If you check v6.0.3 New & Noteworthy:  https://jazz.net/downloads/rational-team-concert/releases/6.0.3?p=news#eclipse-client, Eclipse client is no longer supporting v3.6.x hence the download is now providing v4.2.2 based. however, Knowledge center still suggests "you must use the Client for Eclipse 3.6.x IDE" which is not existing in 6.0.3 now:
http://www.ibm.com/support/knowledgecenter/SSCP65_6.0.3/com.ibm.team.reports.doc/topics/t_ccm_install_birt.html

I think you may need to contact IBM support to get this clarified/updated.


permanent link
Milan Krivic (9807158130) | answered Jan 25 '17, 5:23 a.m.
edited Jan 25 '17, 5:24 a.m.

 Hi Kevin,


I know that, I 've already seen that, but if we still decide to use RTC 6.0.1 for eclipse 3.6, we can't run that reports on CLM server version 6.0.3, even we added neccessary *.jar files "org.eclipse.birt.report.data.oda.jdbc_4.4.2.v201410272105.jar". 
We need to use live reporting with SQL writing as I described before, not usual reporting with existing datasets.

I've already contacted IBM support.
Thanks, and Regards,
Milan

Your answer


Register or to post your answer.